Bug 211419 - Use libldif shared library from Mozldap instead of our own static library
Use libldif shared library from Mozldap instead of our own static library
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Directory Server (Show other bugs)
1.0.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nathan Kinder
Viktor Ashirov
:
Depends On:
Blocks: 152373 240316
  Show dependency treegraph
 
Reported: 2006-10-18 19:36 EDT by Nathan Kinder
Modified: 2015-12-07 11:35 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:35:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed Fix (4.42 KB, patch)
2006-10-18 19:36 EDT, Nathan Kinder
no flags Details | Diff

  None (edit)
Description Nathan Kinder 2006-10-18 19:36:26 EDT
In a review of bug# 210736, Rich suggested that we stop building and using the
static libldif library that's in our server, and start using the libldif shared
library from the Mozilla LDAP C SDK instead.

The attached diffs change the autotools DS build-system to not build libldif.a,
and to instead link to the Mozldap libldif60 shared library.  I did not change
the old Makefiles since we will be moving away from those to use the autotools
build-system instead.

I removed the generated Makefile.in changes from the diff to make the review easier.
Comment 1 Nathan Kinder 2006-10-18 19:36:27 EDT
Created attachment 138846 [details]
Proposed Fix
Comment 2 Noriko Hosoi 2006-10-18 19:42:16 EDT
Looks good to me.
I wonder why we did not do this before? ;)
Comment 3 Rich Megginson 2006-10-18 20:40:23 EDT
I think there used to be some functionality we had in our private version that
was not in mozldap.  I don't think that is true anymore.
Comment 4 Nathan Kinder 2006-10-19 11:55:27 EDT
Checked into ldapserver (HEAD).  Thanks to Rich and Noriko for their reviews!

Checking in Makefile.am;
/cvs/dirsec/ldapserver/Makefile.am,v  <--  Makefile.am
new revision: 1.4; previous revision: 1.3
done
Checking in Makefile.in;
/cvs/dirsec/ldapserver/Makefile.in,v  <--  Makefile.in
new revision: 1.4; previous revision: 1.3
done

Note You need to log in before you can comment on or make changes to this bug.