Bug 21150 - Can't force filetype to magic...
Summary: Can't force filetype to magic...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rhs-printfilters   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-20 23:03 UTC by Johnray Fuller
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-20 23:03:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Johnray Fuller 2000-11-20 23:03:08 UTC
Hello Crutcher,

Unfortunately, rhs-printfilters do not have the ability to force file types
past magic. Magic therefore can misinterpret files. This lead to the
notorous error:

"No way to print
 this type of input file: fsav (linux) virus (2570-11-10)"

Even a simple command like:

ls -l | lpr

can yield this result.

The only work around I've seen is to pipe the text through a postscript
generator like mpage.

So the above command would have to be:

ls -l | mpage -1 -o | lpr

This will print because magic will correctly ID it as postscript.

At any rate, rhs-printfilters should have the ability to force file types
to magic to prevent such misidentification.

Johnray
Support Services

Comment 1 Crutcher Dunnavant 2001-02-01 22:08:01 UTC
The fsav magic virus is dead in magic. The printing system is very different.
There is still no simple way to force file type, but it is much smarter.


Note You need to log in before you can comment on or make changes to this bug.