Bug 211527 - Delete last revision of file creates Internal Server Errors
Delete last revision of file creates Internal Server Errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Web Site (Show other bugs)
rhn500
All Linux
medium Severity medium
: ---
: ---
Assigned To: Grant Gainey
Beth Nackashi
:
Depends On:
Blocks: rhn500h-config-mgmt
  Show dependency treegraph
 
Reported: 2006-10-19 16:31 EDT by Ken Ganong
Modified: 2007-04-18 13:51 EDT (History)
1 user (show)

See Also:
Fixed In Version: rhn500h
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-12 22:40:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Ganong 2006-10-19 16:31:06 EDT
Deleting last revision from file delete revision page produces exception and
does not delete revision.

Should delete the file.

2006-10-19 16:23:27,025 [TP-Processor11] WARN 
org.apache.struts.action.RequestProcessor - Unhandled Exception thrown: class
java.lang.IndexOutOfBoundsException
2006-10-19 16:23:27,028 [TP-Processor11] ERROR
com.redhat.rhn.frontend.servlets.SessionFilter - Error during transaction.
Rolling back
javax.servlet.ServletException: Index: 0, Size: 0
        at
org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
        at
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
        at
org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:236)
        at
com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:97)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
        at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:432)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:763)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java(Compiled Code))
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
        at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:69)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
        at
com.redhat.rhn.frontend.servlets.ContextFilter.doFilter(ContextFilter.java:98)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
        at
com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
        at
com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
        at
com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:51)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
        at
com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:95)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
        at
com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:98)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java(Compiled
Code))
        at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:214)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at
org.apache.catalina.core.StandardContextValve.invokeInternal(StandardContextValve.java:198)
        at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:152)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
        at
org.apache.catalina.core.StandardPipeline.invoke(StandardPipeline.java:520)
        at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:137)
        at
org.apache.catalina.core.StandardValveContext.invokeNext(StandardValveContext.java:104)
Caused by: java.lang.IndexOutOfBoundsException: Index: 0, Size: 0
        at java.util.ArrayList.RangeCheck(ArrayList.java(Inlined Compiled Code))
        at java.util.ArrayList.get(ArrayList.java(Compiled Code))
        at
com.redhat.rhn.domain.config.ConfigurationFactory.getMaxRevisionForFile(ConfigurationFactory.java:820)
        at
com.redhat.rhn.domain.config.ConfigurationFactory.removeConfigRevision(ConfigurationFactory.java:676)
        at
com.redhat.rhn.manager.configuration.ConfigurationManager.deleteConfigRevision(ConfigurationManager.java:1156)
        at
com.redhat.rhn.frontend.action.configuration.files.DeleteRevisionAction.execute(DeleteRevisionAction.java:58)
        at
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
        ... 51 more
Comment 1 Ken Ganong 2006-10-30 11:20:56 EST
fixed in revision 105039.
Comment 2 Ken Ganong 2006-11-13 12:18:23 EST
Moving bugs to ON_DEV
Comment 3 Ken Ganong 2006-12-05 09:56:12 EST
Moving my bugs to ON_QA
Comment 4 Ken Ganong 2006-12-15 15:56:08 EST
Passing on my config management bugs to ggainey
Comment 5 wes hayutin 2007-01-04 17:02:11 EST
this looks like its fixed to me..
Comment 6 Brandon Perkins 2007-03-12 22:40:19 EDT
Closed in the rhn500h Release.

Note You need to log in before you can comment on or make changes to this bug.