Bug 211581 - OpenGL apps hang X server on Matrox G400
OpenGL apps hang X server on Matrox G400
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-20 05:07 EDT by Mark McClelland
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-24 21:20:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.00 KB, text/plain)
2006-10-20 05:07 EDT, Mark McClelland
no flags Details
Xorg.0.log (60.90 KB, text/plain)
2006-10-20 05:10 EDT, Mark McClelland
no flags Details

  None (edit)
Description Mark McClelland 2006-10-20 05:07:56 EDT
Description of problem:
Whenever I try to start any OpenGL app on this system, the screen freezes as
soon as the app's window appears (presumably the instant the OpenGL surface is
created). If I ssh in, I can see that the "Xorg" process is using 100% CPU. I
can kill -9 it, causing the screen to go black, but I can't get X to work again
without a reboot.

The card in question is a Matrox G400 32MB. I tried it at both 16 and 24 bit
color depth, with the same results.

Version-Release number of selected component (if applicable):
mesa-libGL-6.5.1-7.fc6
xorg-x11-server-Xorg-1.1.1-47.fc6
xorg-x11-drv-mga-1.4.2-1.fc6

How reproducible:
Every time.

Steps to Reproduce:
1. run glxgears or enable compiz
  
Actual results:
Screen is frozen until system is rebooted.
Comment 1 Mark McClelland 2006-10-20 05:07:56 EDT
Created attachment 138954 [details]
xorg.conf
Comment 2 Mark McClelland 2006-10-20 05:10:11 EDT
Created attachment 138955 [details]
Xorg.0.log
Comment 3 Mark McClelland 2006-11-10 00:34:01 EST
This problem is likely fixed in mga driver 1.4.4 according to
https://bugs.freedesktop.org/show_bug.cgi?id=8666

I'll build that version from source tarball and report results here.
Comment 4 Mark McClelland 2006-11-10 02:56:57 EST
OpenGL is working under 1.4.4 so far. The only problems are that the mouse
pointer disappears and/or leaves a trail of corruption when moved over an OpenGL
surface, and the right side of the screen isn't rendered properly when using
compiz at 1280x1024. IIRC the former problem dates back to FC3 or earlier, and
the latter is probably a 1024x1024 texture size hardware limitation, so I see no
obvious harm in updating FC6 to the 1.4.4 driver.

 
Comment 5 Adam Jackson 2006-12-11 16:12:08 EST
1.4.5-2 (resync with rawhide) is headed to fc6-u-t now.
Comment 6 Adam Jackson 2007-01-24 21:20:04 EST
Pushed to fc6-updates.  I assume it worked, since no one complained...
Comment 7 Hardy Mayer 2007-01-29 12:44:38 EST
Since updating to FC6 on a system with a Matrox Millenium G200 card, the 
X-display is unusable (I tried several Monitors) -- the problem appeared 
already during the boot from the FC6 iso CD. -- the display is grainy and can 
hardly be read, particularly at 1280x1024. 
Comment 8 Hardy Mayer 2007-01-29 12:48:37 EST
Hope the update to xorg-x11-drv-mga-1.4.5-2.fc6 will help (I will test the 
machine later today)

Note You need to log in before you can comment on or make changes to this bug.