Bug 21159 - (MGA G200)Switching VTs immediately after login crashes Xserver
Summary: (MGA G200)Switching VTs immediately after login crashes Xserver
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-21 01:43 UTC by Ed McKenzie
Modified: 2007-04-18 16:29 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-11-05 16:18:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed McKenzie 2000-11-21 01:43:37 UTC
Logging into gdm and switching away to a text VT before GNOME is done
loading causes the Xserver to die, restarting gdm. The problem seems to go
away if all dri-related stuff is disabled in XF86Config-4.

mgag200 agp board, via mvp3 chipset, amd k6-2/400, stock RH7 install.

Comment 1 Mike A. Harris 2001-04-01 12:31:55 UTC
What bit depth are you using?

Comment 2 Ed McKenzie 2001-04-01 17:50:26 UTC
The bit depth wasn't the issue; this was repeatable in both 16 and 24bpp.
Changing the keyboard repeat settings in the GNOME Control Center is all that's
necessary to break this from a clean user profile.

Comment 3 Mike A. Harris 2001-05-25 11:42:32 UTC
What release of XFree86 are you using when you experience this?
Please attach your uncmpressed XF86Config-4 and XFree86.0.log from
after a crash.  Do not start X after the crash, or the new server will
overwrite the old crash log.  Attach them using the link below.

Comment 4 Ed McKenzie 2001-09-01 15:27:10 UTC
I tried this with the latest 4.1.0 from rawhide (a few days old), and this is
still broken.  The XFree logs show that the server dies with a sig11.

Comment 5 Mike A. Harris 2001-11-05 13:05:23 UTC
Are you using Red Hat Linux 7.1 or 7.2 now?  If so, I'd like to update
the report to reflect the current version that is failing.  Thanks

Comment 6 Ed McKenzie 2001-11-05 16:18:17 UTC
Currently neither, but IIRC I couldn't easily reproduce this on roswell2.  In 

any case, I doubt this bug will be a problem for most users

Comment 7 Mike A. Harris 2002-02-09 01:12:26 UTC
Ok, I'm closing the bug since you've indicated it isn't easily
reproduceable.  I suspect it was perhaps related to VT switch
problems that were solved a while back with fixes to the locking
in the kernel's console handling code.  If it persists, please
reopen, and attach you X server log and configs using the link
below.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.