Bug 211590 - kernel bug (kernel/rwsem.c:20) in 2.6.18-1.2200.fc5 suspend/resume from disk
kernel bug (kernel/rwsem.c:20) in 2.6.18-1.2200.fc5 suspend/resume from disk
Status: CLOSED DUPLICATE of bug 201508
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-20 08:21 EDT by Sonal Santan
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 17:49:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
result of dmesg > dmesg.txt (30.09 KB, text/plain)
2006-10-20 08:21 EDT, Sonal Santan
no flags Details

  None (edit)
Description Sonal Santan 2006-10-20 08:21:24 EDT
Description of problem:
I see a kernel BUG message when doing suspend/resume on my Dell Latitude D810
laptop. This happens only with kernel 2.6.18-1.2200.fc5. I have been using
kernel 2.6.17-1.2187_FC5 without any such error. Here is what shows up in my dmesg

Stopping tasks:
===========================================================================================================================|
Shrinking memory... done (71681 pages freed)
pnp: Device 00:0b disabled.
eth1: Going into suspend...
..............................
swsusp: Need to copy 63769 pages
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
swsusp: Restoring Highmem
BUG: sleeping function called from invalid context at kernel/rwsem.c:20
in_atomic():0, irqs_disabled():1
 [<c0403f10>] dump_trace+0x69/0x1af
 [<c040406e>] show_trace_log_lvl+0x18/0x2c
 [<c04045e9>] show_trace+0xf/0x11
 [<c0404673>] dump_stack+0x15/0x17
 [<c042ef78>] down_read+0x12/0x1f
 [<c0427923>] blocking_notifier_call_chain+0xe/0x29
 [<c05970df>] cpufreq_resume+0x118/0x13f
 [<c053f3d4>] __sysdev_resume+0x20/0x53
 [<c053f515>] sysdev_resume+0x16/0x47
 [<c05435a1>] device_power_up+0x5/0xa
 [<c0437299>] swsusp_suspend+0x74/0x90
 [<c0437720>] pm_suspend_disk+0x43/0xc9
 [<c04368bc>] enter_state+0x52/0x14f
 [<c0436a3e>] state_store+0x85/0x99
 [<c04969ea>] subsys_attr_store+0x1e/0x22
 [<c0496adc>] sysfs_write_file+0xa6/0xcc
 [<c0461292>] vfs_write+0xa8/0x159
 [<c04617d8>] sys_write+0x41/0x67
 [<c0402d9b>] syscall_call+0x7/0xb
DWARF2 unwinder stuck at syscall_call+0x7/0xb
Leftover inexact backtrace:
 =======================


Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2200.fc5

How reproducible:
Always happens during suspend/resume from disk.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Full dmesg is attached.
Comment 1 Sonal Santan 2006-10-20 08:21:24 EDT
Created attachment 138966 [details]
result of dmesg > dmesg.txt
Comment 2 Mischa Soujon 2006-11-14 09:01:59 EST
Loading the self compiled module lt_hoswap (v0.3.6) for kernel 2.6.18-1.2239.fc5
I see the same error message in /var/log/messages:
Nov 12 20:05:22 m-soujon-t42p kernel: Laptop ultrabay hotswap driver version 0.3.6
Nov 12 20:05:22 m-soujon-t42p kernel: lt_hotswap: '\_SB.PCI0.LPC.EC.BAT1' found
(Hot-Swappable)
Nov 12 20:05:22 m-soujon-t42p kernel: lt_hotswap: '\_SB.PCI0.IDE0.SCND.MSTR'
found (Hot-Swappable)
Nov 12 20:05:22 m-soujon-t42p kernel: lt_hotswap:
'\_SB.PCI0.PCI1.DOCK.IDE1.PRIM.MSTR' found (Non-Swa
ppable)
Nov 12 20:05:22 m-soujon-t42p kernel: lt_hotswap: '\_SB.PCI0.LPC.FDC.FDD0' found
(Hot-Swappable)
Nov 12 20:05:22 m-soujon-t42p kernel: lt_hotswap: '\_SB.PCI0.PCI1.DOCK' found
(Hot-Swappable)
Nov 12 20:05:22 m-soujon-t42p kernel: BUG: sleeping function called from invalid
context at kernel/rw
sem.c:20
Nov 12 20:05:22 m-soujon-t42p kernel: in_atomic():0, irqs_disabled():1
Nov 12 20:05:22 m-soujon-t42p kernel:  [<c0403f10>] dump_trace+0x69/0x1af
Nov 12 20:05:22 m-soujon-t42p kernel:  [<c040406e>] show_trace_log_lvl+0x18/0x2c
Nov 12 20:05:22 m-soujon-t42p kernel:  [<c04045e9>] show_trace+0xf/0x11
Nov 12 20:05:22 m-soujon-t42p kernel:  [<c0404673>] dump_stack+0x15/0x17
Nov 12 20:05:22 m-soujon-t42p kernel:  [<c042ef90>] down_read+0x12/0x1f
Nov 12 20:05:22 m-soujon-t42p kernel:  [<c04df5a9>] pci_find_device+0x58/0xa7
Nov 12 20:05:22 m-soujon-t42p kernel:  [<c05529f8>] init_hwif_default+0x28/0xeb
Nov 12 20:05:22 m-soujon-t42p kernel:  [<c05535c3>] ide_unregister+0x23f/0x571
Nov 12 20:05:22 m-soujon-t42p kernel:  [<f8b7d291>] lths_module_init+0x291/0x29b
[lt_hotswap]
Nov 12 20:05:22 m-soujon-t42p kernel:  [<c0434216>] sys_init_module+0x14b9/0x160a
Nov 12 20:05:22 m-soujon-t42p kernel:  [<c0402d9b>] syscall_call+0x7/0xb
Nov 12 20:05:22 m-soujon-t42p kernel: DWARF2 unwinder stuck at syscall_call+0x7/0xb
Nov 12 20:05:22 m-soujon-t42p kernel: Leftover inexact backtrace:
Nov 12 20:05:22 m-soujon-t42p kernel:  =======================
Comment 3 Nigel Cunningham 2006-12-21 17:49:59 EST
This is a duplicate of 201508. Thanks, though, for reporting it.

*** This bug has been marked as a duplicate of 201508 ***

Note You need to log in before you can comment on or make changes to this bug.