Bug 211615 - Dep loop between pam and coreutils
Dep loop between pam and coreutils
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: coreutils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-20 10:18 EDT by James Olin Oden
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-16 13:13:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Change coreutils spec to produce coreutils-su (1.34 KB, patch)
2006-10-20 10:18 EDT, James Olin Oden
no flags Details | Diff
Fixed to include pam dep in the sub package with new name coreutils-pam (605 bytes, patch)
2006-10-20 11:04 EDT, James Olin Oden
no flags Details | Diff

  None (edit)
Description James Olin Oden 2006-10-20 10:18:02 EDT
Description of problem:
pam and coreutils have a dependency loop amongst themselves.  Pam requires the 
use of certain coreutils binaries in its scriptlets, and the coreutils su 
command links to libpam and libpam_misc.  Presently this is worked around via 
dep whitout.

Version-Release number of selected component (if applicable):
5.2.1-31.2

How reproducible:
Its always there.

Steps to Reproduce:
N/A
  
Actual results:
N/A

Expected results:
N/A

Additional info:
Its easy enough to really break this loop by putting su in a subpackage (call 
it coreutils-su).  I will attach a patch to the spec file to this end.
Comment 1 James Olin Oden 2006-10-20 10:18:03 EDT
Created attachment 138975 [details]
Change coreutils spec to produce coreutils-su
Comment 2 Tim Waugh 2006-10-20 10:32:09 EDT
Thanks for the report and the patch.  I'm changing the product and version of
this to Fedora Core devel -- we don't normally break out subpackages during a
support cycle.

I think any sub-package made for this reason ought to be called 'coreutils-pam'
in case there other other pam-using utilities in future.
Comment 3 James Olin Oden 2006-10-20 10:51:30 EDT
Sound like a good name and sound reasoning.  Yeah, and you could say something 
to that effect in the description (which btw, I forgot to change the 
description of the sub-package in my patch from the place I was cutting and 
pasting from). 

Thanks again...james
Comment 4 James Olin Oden 2006-10-20 11:04:24 EDT
Created attachment 138985 [details]
Fixed to include pam dep in the sub package with new name coreutils-pam

OK, missed a manual dep on pam.  BTW, I think we could completely get rid of
the manual dep as it will be picked up automatically by RPM due to su linking
against libpam.
Comment 5 James Olin Oden 2006-10-20 11:08:58 EDT
BTW, once this patch is in place, anconda's Whitout.py file can have the 
pam>coreutils whiteout line removed.  Which was my motivation in RHEL 4 (long 
story, be happy to tell outside of bugzilla).
Comment 6 Tim Waugh 2007-01-18 10:58:36 EST
Er.. did you test this patch?  There seem to be several problems with it.
Comment 7 Tim Waugh 2007-04-16 13:13:14 EDT
No response; closing.

Note You need to log in before you can comment on or make changes to this bug.