Bug 211624 - new vm wizard issues
new vm wizard issues
Status: CLOSED DUPLICATE of bug 220036
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-20 10:47 EDT by Matthias Clasen
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-19 16:22:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-10-20 10:47:12 EDT
Sometimes when I press the "Finish" button, the graphical console does not come
up. The vm starts running ok though, and I can get the console by opening it
from virt-manager...

Also, I think the wizard window should close as soon as the window with the
progressbar comes up. Or at least it should become insensitive.
Comment 1 Daniel Berrange 2006-10-25 09:47:36 EDT
Change to disable sensisitivity during VM creation is upstream

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=bb3152c45312

Need to further investigate cause of console not always appearing.
Comment 2 Bernard Johnson 2006-12-03 00:24:41 EST
Regarding the wizard window not closing:

I have the preference set to automatically open a new console on new domains.  I
don't get a console nor does the wizard close (in the normal failure mode - it
does work sometimes).  

I suspect that the console creation is throwing an error and it's being caught
further up (thus bypassing the window.close() statement).
Comment 3 Daniel Berrange 2006-12-03 09:46:43 EST
Does the guest domain itself actually get created though, or has the guest
domain failed to start ? (If domain creation fails, then we delibrately don't
open the console window & leave the wizard visible)

If you can check /root/.virt-manager/virt-manager.log to see if there's any
errors that'd be helpful.
Comment 4 Bernard Johnson 2006-12-03 14:48:11 EST
Yes, the guest is created and running.  If I double-click on the VMM display for
the host I just started, the console opens.

I should note that I first mistyped the install location and kickstart URLs the
first time I tried to create the domain.  Perhaps some status is getting left
over from that and then the next time I try it doesn't open a console.

Here is a failure to open the console when the the new domain is created.

/root/.virt-manager/virt-manager.log:

Sun, 03 Dec 2006 12:35:18 DEBUG    Creating a VM KICKSTART
  UUID: f9a7e476-f55f-4865-8cbb-39e23df0d2e4
  Source: http://192.168.1.105/install-images/CentOS4
  Kickstart: http://192.168.1.105/install-images/kickstart/CentOS4.ks
  Memory: 384
  # VCPUs: 1
  Filesize: 1.953125
  Disk image: /home/xen/KICKSTART.img
Sun, 03 Dec 2006 12:35:18 DEBUG    Starting background install process
Sun, 03 Dec 2006 12:35:19 DEBUG    Creating guest from '<domain type='xen'>
  <name>KICKSTART</name>
  <memory>393216</memory>
  <uuid>f9a7e476-f55f-4865-8cbb-39e23df0d2e4</uuid>
  
  <os>
    <type>linux</type>
    <kernel>/var/lib/xen/vmlinuz.ghZ_Oh</kernel>
    <initrd>/var/lib/xen/initrd.img.r_Vba5</initrd>
    <cmdline> method=http://192.168.1.105/install-images/CentOS4 
ks=http://192.168.1.105/install-images/kickstart/CentOS4.ks</cmdline>
  </os>

  <on_poweroff>destroy</on_poweroff>
  <on_reboot>destroy</on_reboot>
  <on_crash>destroy</on_crash>
  <vcpu>1</vcpu>
  <devices>
    <disk type='file' device='disk'>
      <driver name='tap'/>
      <source file='/home/xen/KICKSTART.img'/>
      <target dev='xvda'/>
    </disk>

    <interface type='bridge'><source bridge='xenbr0'/><mac
address='00:16:3e:18:6c:4c'/><script
path='/etc/xen/scripts/vif-bridge'/></interface>

    <graphics type='vnc' port='-1'/>
  </devices>
</domain>
'
Sun, 03 Dec 2006 12:35:23 DEBUG    Saving XM config file '# Automatically
generated xen config file
name = "KICKSTART"
memory = "384"
disk = [ 'tap:aio:/home/xen/KICKSTART.img,xvda,w', ]
vif = [ 'mac=00:16:3e:18:6c:4c, bridge=xenbr0', ]
vnc=1
vncunused=1
uuid = "f9a7e476-f55f-4865-8cbb-39e23df0d2e4"
bootloader="/usr/bin/pygrub"
vcpus=1
on_reboot   = 'restart'
on_crash    = 'restart'
'
Sun, 03 Dec 2006 12:35:24 DEBUG    Install completed
Comment 5 Daniel Berrange 2006-12-19 16:22:16 EST
Closing this bug a duplicate, because we've since successfully reproduced &
diagnosed this problem in bug 220036 (even though this bug was first, the other
has more details).

*** This bug has been marked as a duplicate of 220036 ***

Note You need to log in before you can comment on or make changes to this bug.