This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 21164 - hard drive install fails from read only filesystem
hard drive install fails from read only filesystem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Brock Organ
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-21 01:49 EST by Need Real Name
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-08 14:51:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2000-11-21 01:49:18 EST
attempting install from hard drive from RH-7.0-respin.
had to use hard drive, installer won't recognize my 
scsi cdrom (SONY on an adaptec, seems odd...).  get 
up to choice of MD5, etc, for passwd file.  leave at
defaults, use "OK".  blam...  looks like the installer
cannot perform the install from a read-only file system
(jaz 2G w/ ro flag set, in this case)?

since i'm not going to pass the jaz drive around the
office writable this leaves us unable to install RH-7.0
for testing.



Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in
run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py",
line 32, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 532, in
getHeaderList



  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 51,
in readHeaders
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 30,
in mountMedia
  File "/usr/lib/anaconda/isys.py", line 99, in mount
    rc = _isys.mount(fstype, device, location, readOnly)
SystemError: (30, 'Read-only file system')

Local variables in innermost frame:
fstype: ext2
location: /tmp/hdimage
devName: /tmp/sdc2
readOnly: 0
device: /tmp/sdc2
Comment 1 Need Real Name 2000-11-21 11:42:26 EST
note:  problem is reproducable.  i can send the entire
dump if it would be useful.
Comment 2 Erik Troan 2000-11-21 13:21:18 EST
Changed anaconda in CVS to mount hard drive install sources readonly -- good
idea.
Comment 3 Aaron Brown 2000-12-13 17:20:35 EST
Verified as resolved.

Note You need to log in before you can comment on or make changes to this bug.