Bug 211652 - crash generates floating point assist faults on ia64
Summary: crash generates floating point assist faults on ia64
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: crash   
(Show other bugs)
Version: 4.4
Hardware: ia64
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Dave Anderson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-20 16:52 UTC by Bryn M. Reeves
Modified: 2018-10-19 19:12 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0188
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 22:45:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace from the location triggering the fp assist fault (7.36 KB, text/plain)
2006-10-20 16:52 UTC, Bryn M. Reeves
no flags Details
prctl(PR_SET_FPEMU, 1, 0, 0, 0); (553 bytes, patch)
2006-10-20 18:13 UTC, Dave Anderson
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0188 normal SHIPPED_LIVE crash bug fix update 2007-04-27 20:44:59 UTC

Description Bryn M. Reeves 2006-10-20 16:52:47 UTC
The gdb module in crash attempts to manipulate floating point values via ldexp
when printing backtraces. If the values in the fp registers contain
denormals/NANs, the kernel logs a floating point software assist fault.

The messages are low in volume and the concern is primarily cosmetic.

Steps to reproduce:

# rpm -ivh kernel-2.6.9-42.EL.ia64.rpm
# crash /usr/lib/debug/lib/modules/2.6.9-42.EL/vmlinux

crash> foreach bt

# dmesg|grep "assist fault"
kernel: crash(12028): floating-point assist fault at ip 20000000000d4382, isr
0000020000001001

The ip is always inside ldexp, being called from the gdb value_print function
(see attached backtrace)

Comment 1 Bryn M. Reeves 2006-10-20 16:52:58 UTC
Created attachment 139001 [details]
backtrace from the location triggering the fp assist fault

Comment 2 Dave Anderson 2006-10-20 17:47:26 UTC
Interesting, although I can't reproduce it, at least with 2.4.21-47.EL.

It looks like the messages can be turned off on a per-task basis
with a prctl PR_SET_FPEMU in order to set the IA64_THREAD_FPEMU_NOPRINT
bit in its current->thread.flags.




Comment 3 Dave Anderson 2006-10-20 18:13:39 UTC
Created attachment 139012 [details]
prctl(PR_SET_FPEMU, 1, 0, 0, 0);

Bryn,

If you get the chance, can you apply this patch to the ia64.c file
in the crash utility sources, rebuild, and see if it clears up the
log messages?

The patch is against the 4.0-3.7 version of crash, but will probably
apply to whatever you're using.  But the easiest thing to do would
be to go to http://people.redhat.com/anderson and download the
crash-4.0-3.7.tar.gz file.  Then:

# tar xzf crash-4.0-3.7.tar.gz
# cd crash-4.0-3.7
# patch -p0 < ia64_prctl.patch
# make
...
# ./crash

and test it out.

Comment 4 Dave Anderson 2006-10-20 19:27:14 UTC
Or, alternatively, this should accomplish the same thing with
the crash utility unmodified:

 # prctl --fpemu=silent crash 

Comment 6 Bryn M. Reeves 2006-10-23 11:07:52 UTC
Have tested both the prctl workaround and the patch (applied to the U4 crash
sources - went in fine with a bit of offset) - both worked like a charm, thanks!


Comment 7 Dave Anderson 2006-10-24 12:35:13 UTC
This should go into the RHEL4-5 crash utility errata.

Comment 8 RHEL Product and Program Management 2006-10-24 12:43:32 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 9 Dave Anderson 2006-11-03 15:26:26 UTC
I am currently filing the RHEL4-U5 crash utility errata, and
for inclusion this Bugzilla needs:

 rhel-4-5 +
 devel.ack + 
 qa_ack +

Thanks,
 Dave


Comment 11 Dave Anderson 2006-11-03 19:40:31 UTC
crash version 4.0-3.9 checked into RHEL4 CVS.

(still requires devel_ack+, qa_ack+ and rhel-4.5+)

Comment 16 Red Hat Bugzilla 2007-05-01 22:45:21 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0188.html



Note You need to log in before you can comment on or make changes to this bug.