Bug 211671 - No gui equivalent of xm create
No gui equivalent of xm create
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-manager (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
:
: 214723 (view as bug list)
Depends On: 210648 211928
Blocks: 197865 214707 214724 223508 223778
  Show dependency treegraph
 
Reported: 2006-10-20 14:39 EDT by Matthias Clasen
Modified: 2007-11-30 17:07 EST (History)
8 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-19 08:43:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-10-20 14:39:58 EDT
I could not find a gui equivalent of xm create in virt-manager. The only thing
that sounds related, "Restore", seems to be intended only for previously saved
snapshots. A nicely integrated way to do this would be to have a right click
action in nautilus for xen instances (see bug 211592), but there should also be
a way to do it in virt-manager.
Comment 1 RHEL Product and Program Management 2006-10-24 14:33:36 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 2 Daniel Berrange 2006-11-09 08:19:47 EST
*** Bug 214723 has been marked as a duplicate of this bug. ***
Comment 9 Jay Turner 2006-12-13 15:26:39 EST
QE ack for RHEL5.
Comment 10 Ken Reilly 2006-12-14 18:44:38 EST
Daniel, 

Do you agree the resolution for this in rhel-5.0.0 is to include a release note?
If so, please remember the content cutoff for release note content is Tuesday,
Decemeber 19, 2006. If not, please provide an assessment and a status update so
I can determine if this bug can/should block rhel-5.0.0 RC. 

Thanks in advance. 


Ken
Comment 11 Daniel Berrange 2006-12-14 23:11:25 EST
There is prototype code to implement the 'start' capability in virt-manager,
however, this is very invasive and has many known problems yet to be resolved.
Thus I cannot recommend including it in RHEL-5 GA.  

So, yes, I agree that documenting the use of 'xm create' workaround to start an
existing domain is the only practical solution for RHEL-5 GA. 
Comment 13 Don Domingo 2006-12-17 19:32:02 EST
the following has been added to the RC release notes:

<quote>
At present, the Virtualization feature has the following limitations:

<snip>
* The xm create command does not have a graphical equivalent in Virtual Machine
Manager.
</quote>
Comment 15 Ken Reilly 2006-12-19 08:16:07 EST
Thanks Dan and Dom for following-up! I've set the closker to ? and expect PM to
approve it as a blocker for RHEL 5.0.0 GA. 
Comment 19 Jay Turner 2007-01-19 08:43:39 EST
Closing out.  Please ensure that a 5.1 bug is entered to track resolution of the
original issue.
Comment 20 Stephen Tweedie 2007-01-22 08:19:46 EST
Cloned for 5.1 as bug 223508.

Note You need to log in before you can comment on or make changes to this bug.