Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 2116941

Summary: ocf:heartbeat:ethmonitor resource fails to start
Product: Red Hat Enterprise Linux 8 Reporter: Markéta Smazová <msmazova>
Component: resource-agentsAssignee: Oyvind Albrigtsen <oalbrigt>
Status: CLOSED ERRATA QA Contact: cluster-qe <cluster-qe>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 8.7CC: agk, cluster-maint, fdinitto, mjuricek
Target Milestone: rcKeywords: Triaged
Target Release: 8.7Flags: pm-rhel: mirror+
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: resource-agents-4.9.0-29.el8 Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2022-11-08 09:09:07 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Markéta Smazová 2022-08-09 14:59:33 UTC
This bug was initially created as a copy of Bug #2110452


Description of problem:
-----------------------
ocf:heartbeat:ethmonitor resource fails to start


Version-Release number of selected component (if applicable):
-------------------------------------------------------------
resource-agents-4.9.0-27.el8.x86_64
pacemaker-2.1.4-4.el8.x86_64


How reproducible:
----------------
always, easily


Steps to Reproduce:
--------------------
# pcs resource create ethmon1 ocf:heartbeat:ethmonitor interface=ens5


Actual results:
---------------
[root@virt-024 ~]# pcs resource create ethmon1 ocf:heartbeat:ethmonitor interface=ens5
[root@virt-024 ~]# pcs status
Cluster name: STSRHTS15483
Cluster Summary:
  * Stack: corosync
  * Current DC: virt-024 (version 2.1.4-4.el8-dc6eb4362e) - partition with quorum
  * Last updated: Tue Aug  9 16:57:42 2022
  * Last change:  Tue Aug  9 16:57:34 2022 by root via cibadmin on virt-024
  * 2 nodes configured
  * 3 resource instances configured

Node List:
  * Online: [ virt-024 virt-025 ]

Full List of Resources:
  * fence-virt-024	(stonith:fence_xvm):	 Started virt-024
  * fence-virt-025	(stonith:fence_xvm):	 Started virt-025
  * ethmon1	(ocf::heartbeat:ethmonitor):	 Stopped

Failed Resource Actions:
  * ethmon1_start_0 on virt-025 'error' (1): call=18, status='complete', last-rc-change='Tue Aug  9 16:57:34 2022', queued=0ms, exec=253ms
  * ethmon1_start_0 on virt-024 'error' (1): call=18, status='complete', last-rc-change='Tue Aug  9 16:57:34 2022', queued=0ms, exec=141ms

Daemon Status:
  corosync: active/disabled
  pacemaker: active/disabled
  pcsd: active/enabled


Expected results:
-----------------
Resource is started.


Additional info:
-----------------
[root@virt-024 ~]# pcs resource debug-start ethmon1
crm_resource: Error performing operation: Error occurred
Operation force-start for ethmon1 (ocf:heartbeat:ethmonitor) returned 1 (error)
attrd_updater: Unknown option -q
Aug 09 16:58:42 WARNING: attrd_updater: Could not update ethmonitor-ens5 = 1: rc=64

Comment 6 errata-xmlrpc 2022-11-08 09:09:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (resource-agents bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:7443