Bug 2117202 - Regression: Cannot set 2+ ip addresses for bond arp_ip_target option
Summary: Regression: Cannot set 2+ ip addresses for bond arp_ip_target option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 9
Classification: Red Hat
Component: NetworkManager
Version: 9.1
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Fernando F. Mancera
QA Contact: Matej Berezny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-08-10 10:02 UTC by Gris Ge
Modified: 2022-11-15 12:08 UTC (History)
8 users (show)

Fixed In Version: NetworkManager-1.39.90-1.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-11-15 10:50:05 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
NetworkManager trace log (57.94 KB, text/plain)
2022-08-10 10:08 UTC, Gris Ge
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-130814 0 None None None 2022-08-10 10:03:52 UTC
Red Hat Product Errata RHBA-2022:8265 0 None None None 2022-11-15 10:50:16 UTC
freedesktop.org Gitlab NetworkManager NetworkManager-ci merge_requests 1151 0 None opened bond: extend test to support 2 IPs in arp_ip_target 2022-08-24 12:32:03 UTC
freedesktop.org Gitlab NetworkManager NetworkManager merge_requests 1335 0 None opened bond: fix parsing of arp_ip_target to platform 2022-08-11 09:40:03 UTC

Description Gris Ge 2022-08-10 10:02:31 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. sudo nmcli c add type bond ifname bond0 connection.id bond0 bond.options arp_ip_target="192.0.2.1 192.0.2.2",mode=active-backup,arp_interval=10
2. cat /sys/class/net/bond0/bonding/arp_ip_target
3.

Actual results:
Empty arp_ip_target in sysfs.

Expected results:
192.0.2.1 192.0.2.2

Additional info:

This is found by tier1 test case of nmstate CI, hence it is used by layer products. Please fix it ASAP.

Comment 1 Gris Ge 2022-08-10 10:08:53 UTC
Created attachment 1904677 [details]
NetworkManager trace log

Comment 5 errata-xmlrpc 2022-11-15 10:50:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (NetworkManager bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:8265


Note You need to log in before you can comment on or make changes to this bug.