This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 211770 - Auto-generated xorg.conf's are missing parts
Auto-generated xorg.conf's are missing parts
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pyxf86config (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-22 09:53 EDT by Stewart Adam
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-30 18:30:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stewart Adam 2006-10-22 09:53:51 EDT
Description of problem:
Ever since Test2, I think, pyxf86config's been leaving out parts of the
xorg.conf file. For example, it will not create the "files" or "module"
sections, which cause numerous problems.

I've packaged re-packaged drivers from Livna to the the 1.0-9626 version so I
can run AIGLX on my nVidia machine - And the script Livna uses, for example, to
parse xorg.conf and auto-edit fails.

Compiz won't run because of missing GLX and extmod extensions, and the section's
are gone so unless the user knows how to add them, and now scripts can't
auto-edit them in.

Version-Release number of selected component (if applicable):
pyxf86config-0.3.31-2.fc6

How reproducible:
Always

Steps to Reproduce:
1. Reinstall FCT2 or better
2. Install fglrx / nvidia drivers from Livna, or try to enable Compiz
3. A script for auto-editing xorg.conf fails and Compiz won't run
  
Actual results:
Sections are missing from xorg.conf

Expected results:
They are there, even if left empty so autodetection of hardware and settings works.

Additional info:
Comment 1 Adam Jackson 2006-10-30 18:30:42 EST
If the Modules section is omitted, glx and extmod are always loaded.  This is
the intended behaviour, and in fact has always been the case since, oh, XFree86
4.0 or so.  We're just relying on it now.

If external scripts are failing now, it's because they've always _been_ broken.
Comment 2 Stewart Adam 2006-10-30 19:28:37 EST
Sorry, I didn't mean to offend you or anything...

It's odd, though, because Compiz would refuse to run until I manually added
extmod - Many on fedoraforum.org are seeing the same thing.
Comment 3 Loz Saunders 2006-12-12 19:53:38 EST
I too had to manually create a 'modules' section and add 'load "extmod"' to 
xorg.conf when using the Livna nvidia-legacy driver (7184); otherwise, the
transparency on the rounded corners of windows was missing (replaced by black)
and mplayer was surrounded by a black rectangle and produced the error message,
"Sorry, your system doesn't support the XShape Extention". 

Adding the above entry to xorg.conf fixes the problem. Removing it makes the
problem reapear, so on my system, at least, extmod _isn't_ loaded if this is
omited from xorg.conf (BTW running release version fc6)

Note You need to log in before you can comment on or make changes to this bug.