Bug 211790 - Problem with kernel modules
Problem with kernel modules
Status: CLOSED DUPLICATE of bug 211941
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-22 17:26 EDT by Łukasz Trąbiński
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-24 14:26:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Łukasz Trąbiński 2006-10-22 17:26:59 EDT
Description of problem:

I'm tring to compile some kernel modul (cisco vpn) on FC6.
First i can't find config.h header:

[lukasz@evil ~]$ rpm -q kernel-devel
kernel-devel-2.6.18-1.2798.fc6
[lukasz@evil ~]$ rpm -ql kernel-devel |grep "linux/config\.h" |wc -l
0
OK, i can copy config.h from different location/source. When compiling was
successful and when i tring insert module info system:

[root@evil ~]# modprobe cisco_ipsec
FATAL: Error inserting cisco_ipsec
(/lib/modules/2.6.18-1.2798.fc6/CiscoVPN/cisco_ipsec.ko): Invalid module format
in system logs i can find information like this:

cisco_ipsec: version magic '2.6.18-1.2798.fc6 SMP mod_unload 686 REGPARM
4KSTACKS gcc-4.1' should be '2.6.18-1.2798.fc6 SMP mod_unload 586 REGPARM
4KSTACKS gcc-4.1'


Version-Release number of selected component (if applicable):
FC6 upgraded from FC5

[root@evil ~]# rpm -q kernel
kernel-2.6.18-1.2798.fc6
[root@evil ~]# rpm -q gcc
gcc-4.1.1-30
[root@evil ~]# rpm -q glibc
glibc-2.5-3
[root@evil ~]# rpm -q kernel-devel
kernel-devel-2.6.18-1.2798.fc6



How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I know that this example is not very good, i'm tring to compile strange module
from Cisco :) but it worked and compiled well on FC5
Comment 1 petrosyan 2006-10-24 12:45:50 EDT
What do you get when you run:

rpm -q --queryformat "%{name}-%{version}-%{release}.%{arch}\n" kernel

?
Comment 2 Łukasz Trąbiński 2006-10-24 14:26:03 EDT
(In reply to comment #1)
> What do you get when you run:
> 
> rpm -q --queryformat "%{name}-%{version}-%{release}.%{arch}\n" kernel
> 
> ?

OK, it was
kernel-2.6.18-1.2798.fc6.i586
shuld be
kernel-2.6.18-1.2798.fc6.i686

kernel-2.6.18-1.2798.fc6.i686 works OK. Thank You. It's not bug, it was my fault.




Comment 3 petrosyan 2006-10-24 14:29:46 EDT
Its not your fault. It was caused by anaconda incorrectly upgrading your kernel.
This has been filed as bug #211941
Please add your comments to that bug.
Comment 4 Łukasz Trąbiński 2006-10-24 14:36:13 EDT

*** This bug has been marked as a duplicate of 211941 ***

Note You need to log in before you can comment on or make changes to this bug.