Bug 2118 - finger doesn't check for exact matches unless -m is passed
finger doesn't check for exact matches unless -m is passed
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: finger (Show other bugs)
6.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-11 01:03 EDT by Nalin Dahyabhai
Modified: 2015-01-07 18:36 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-28 11:41:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 1999-04-11 01:03:50 EDT
Unless a user invokes finger with the '-m' switch, it doesn't
bother to check for an exact match for a user name using
getpwnam().  If the nsswitch module that contains the info
about that user doesn't provide a getpwent() function (like
hesiod), finger will always fail without that '-m' flag.
Whether this is actually a bug is debatable because the man
page isn't too clear on what should be done.  I'm about to
mail in a patch to fix this anyway.

------- Email Received From  Nalin Dahyabhai <nalin@thermo.stat.ncsu.edu> 04/11/99 01:07 -------


------- Email Received From  Stepan Kasal <kasal@matsrv.math.cas.cz> 05/10/99 08:56 -------
Comment 1 Jeff Johnson 1999-07-28 11:41:59 EDT
Fixed in finger-0.10-25. Thanks for the patches.

Note You need to log in before you can comment on or make changes to this bug.