Bug 211804 - Lock at "Initializing hardware... storage network" caused by Sigmatel STAC9220 HD Audio controller enabled in BIOS.
Lock at "Initializing hardware... storage network" caused by Sigmatel STAC922...
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Martuccelli
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-10-23 00:59 EDT by Jacky Cui
Modified: 2012-06-20 11:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-06-20 11:58:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
jwltest kernel failed screen (180.91 KB, image/pjpeg)
2006-10-23 00:59 EDT, Jacky Cui
no flags Details

  None (edit)
Description Jacky Cui 2006-10-23 00:59:45 EDT
Install RHEL AS4 UP4 on our designed board ( Intel Yonah T2500 2M 2.0GHz, 
Intel mobile 945GM NB, Intel ICH7 SB, SigmaTel STAC9220 HDA audio ), when 
first boot after completed install, it will hang at:
"Initializing Hardware...Storage Network" 

I tried with test kernel from http://people.redhat.com/linville/kernels/rhel4/ 
enable HDA audio, fail at kernel panic.(see picture attached)

Steps to Reproduce:
1. Install RHEL4 AS4 UP4 on our hardware platform (see above) 
2. Boot new install.
Comment 1 Jacky Cui 2006-10-23 00:59:45 EDT
Created attachment 139095 [details]
jwltest kernel failed screen
Comment 2 German Monroy 2006-10-25 17:40:36 EDT
just to make sure, could you please disable the network in BIOS and try again
the jwltest kernel?

also could you please try updating the BIOS?  

we have a desktop 945G board with the same codec that is booting fine and
playing sounds without a problem...
Comment 3 Jacky Cui 2006-10-25 22:00:23 EDT
OK, clear for one thing, this hardware platform is designed by ourself, BIOS 
team provide BIOS to us for testing, I think the BIOS is newest one.(do you 
provide which part of BIOS should be adjusted for RHEL4? if have, I will ask 
BIOS team to modify.)

I tried with network disable and booting with jwltest kernel, the result is 
same as comment #1 picture, also failed.

I think 945G is different with 945GM.
Comment 4 John W. Linville 2006-10-26 11:16:00 EDT
FWIW the time I saw behaviour like this on a pre-release HP box, it was fixed 
by a BIOS update on that box.  I don't know exactly (or even generlaly) what 
they changed...
Comment 5 Jacky Cui 2006-10-26 22:20:25 EDT
we have tested this using Knoppix Linux 5.01 english, boot without error and 
sound work well. (kernel 2.6.17)
can this exclude BIOS bugs of our platform?
Comment 6 Jacky Cui 2006-10-26 22:22:03 EDT
Append one thing;

We also tried with RHEL AS4 (no update), the system booting ok.
Comment 7 Brian Maly 2008-02-15 10:33:27 EST
Can you please test with a recent RHEL4 kernel? There have been many updates to
ALSA (including the sigmatel code) since this bug was reported which may resolve
this issue.

If it is not fixed, please, attach output from 'cat /proc/asound/card0/codec*'
so the exact codec can be identified. Thanks.
Comment 9 Jiri Pallich 2012-06-20 11:58:31 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.