This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 21187 - hwclock is never called on shutdown
hwclock is never called on shutdown
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Dale Lovelace
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-21 11:33 EST by Need Real Name
Modified: 2014-03-16 22:17 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-22 11:53:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Minor cosmetic fixes when setting system and hardware clocks (719 bytes, patch)
2001-03-26 12:40 EST, chris
no flags Details | Diff

  None (edit)
Description Need Real Name 2000-11-21 11:33:10 EST
At least as of redhat 6.1, hwclock --systohc is never called
automatically.  This strikes me as a bug, as the system will often have
correct time via ntp while running, but the hardware only gets
resychronized by hand.  Come next reboot, lather, rinse, repeat.
Comment 1 Pekka Savola 2000-11-21 12:27:26 EST
Still there in RHL7 too.

I've gotten around with this by creating a /etc/cron.daily/set-clock script which 
writes down the time every day.  Works when your system crashes too ;-)

Seems more of an initscripts than util-linux problem.
Comment 2 Bill Nottingham 2000-12-12 03:20:04 EST
Will be fixed in initscripts-5.53-1; thanks for the report!
Comment 3 chris 2001-01-25 08:15:21 EST
However, the fix currently in RawHide (initscripts-5.54-1) seems to be wrong: it
doesn't take account of the setting of UTC and ARC in /etc/sysconfig/clock. 
Presumably it ought either to call /usr/sbin/setclock instead, or have some
extra code (analogous to that in /etc/rc.d/rc.sysinit) to take account of those
settings?
Comment 4 Bill Nottingham 2001-01-25 13:06:45 EST
Yep, that got fixed a couple of builds later. :)
Comment 5 chris 2001-03-26 12:39:02 EST
Great.  Very minor, picky nit, but presumably $CLOCKDEF was meant to be used in
the descriptive string when doing the "runcmd ... /sbin/hwclock"?

While we're on the subject (even more minor, pickier nit!), there's an extra
space which probably wasn't intended in the corresponding place in
/etc/rc.d/rc.sysinit.

Patch attached to fix both.
Comment 6 chris 2001-03-26 12:40:03 EST
Created attachment 13704 [details]
Minor cosmetic fixes when setting system and hardware clocks

Note You need to log in before you can comment on or make changes to this bug.