Bug 2119089 - Explore page is lacking content by default, has an odd narrow width
Summary: Explore page is lacking content by default, has an odd narrow width
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Milan Crha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-08-17 13:37 UTC by Allan Day
Modified: 2022-08-26 09:42 UTC (History)
3 users (show)

Fixed In Version: gnome-software-43.beta-3
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-26 09:42:12 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot (270.20 KB, image/png)
2022-08-17 13:37 UTC, Allan Day
no flags Details

Description Allan Day 2022-08-17 13:37:11 UTC
Created attachment 1905961 [details]
Screenshot

Description of problem:

Using a new install of F37, the default view in the Software app is not good. There are no visible app tiles, and the page content is unusually narrow.

Version-Release number of selected component (if applicable):

43.beta-14-gf48d9d23a

Additional info:

Usually there are two sections of app tiles on the explore page. neither of which are visible in my F37 install.

1. "Editor's Choice"

This includes apps that have been specified with the `GnomeSoftware::popular` tag. It is only shown if 12 or more of these apps are present.

Currently `GnomeSoftware::popular` is set upstream, and coincides with the GNOME Circle apps. We currently only have 11 out of 43 of those available to install out of the box in Fedora - hence this section not being shown.

2. New and Updated

Shows apps with recent releases. If fewer than 12 apps are found to meet the requirements, the section isn't shown. Software is only finding 6 of these apps in my install. This could be due to out of date appstream data.

Potential fixes to this issue, therefore:

 1. Ensure that 12 or more Circle apps are available to install
 2. Tag more apps with `GnomeSoftware::popular`
 3. Take steps to ensure that "new and recent" is always populated

I'd prefer not to do 2. There's an upstream process to decide what goes into "Editor's Choice" - I don't think we should interfere with that.

Comment 1 Milan Crha 2022-08-17 13:50:01 UTC
I will return back to the install the https://gitlab.gnome.org/GNOME/gnome-software/-/blob/main/data/assets/org.gnome.Software.Curated.xml . Philip (Withnall) said it's not meant to be used by the distros, the distros are supposed to have their own list, but if you are fine with that listing, then I'll return it back.

With it saved at the right place the `Editor's Choice` section is shown.

Comment 2 Allan Day 2022-08-17 14:34:31 UTC
> I will return back to the install the https://gitlab.gnome.org/GNOME/gnome-software/-/blob/main/data/assets/org.gnome.Software.Curated.xml 

That's option 2 I described above, isn't it? As I said, there's a process for defining that set upstream - it's one of the ways that GNOME advertises the Circle apps [1]. I wouldn't want to undermine what's being done there.

[1] https://circle.gnome.org/

Comment 3 Milan Crha 2022-08-17 15:49:27 UTC
> That's option 2 I described above, isn't it?

Hmm, I did not think of it. The org.gnome.Software.Curated.xml is the old org.gnome.Software.DistroFeatured.xml, expanded and "modernized". The DistroFeatured.xml had been distributed in the gnome-software package before this change.

> it's one of the ways that GNOME advertises the Circle apps [1]. I wouldn't want to undermine what's being done there.

I do not follow, I'm sorry. If the org.gnome.Software.Curated.xml contains mostly the Circle apps, then by adding it to the set of the apps in Fedora means to support it, not to undermine it, no? Undermine it means hiding the Circle apps, thus not distributing the org.gnome.Software.Curated.xml file. What am I missing here?

Comment 4 Allan Day 2022-08-18 10:19:37 UTC
> If the org.gnome.Software.Curated.xml contains mostly the Circle apps, then by adding it to the set of the apps in Fedora means to support it, not to undermine it, no?

I think that it undermines Circle if we promote non-Circle apps as Editor's Choice. It would undermine the work that the Circle team does, since we'd be circumventing their process for what gets shown in that section. Plus, Editor's Choice would no longer be a perk that's exclusive to Circle apps.

Comment 5 Allan Day 2022-08-23 11:12:09 UTC
(In reply to Milan Crha from comment #1)
> I will return back to the install the
> https://gitlab.gnome.org/GNOME/gnome-software/-/blob/main/data/assets/org.
> gnome.Software.Curated.xml . Philip (Withnall) said it's not meant to be
> used by the distros, the distros are supposed to have their own list, but if
> you are fine with that listing, then I'll return it back.

This happened? I see that editor's choice is now populated with non-Circle apps in F37. :(

Comment 6 Milan Crha 2022-08-23 13:44:13 UTC
It happened with gnome-software-43.beta-3 , which is part of the f37 already.

That being said, you want me to revert the above change (possibly within the 43.rc release, which will happen at the end of the next week) and close this as "Expected Behaviour" causing not "Editor's Choice" section in Fedora until some more apps are packages for Fedora directly, right?

Comment 7 Allan Day 2022-08-25 16:32:17 UTC
The only alternative that I can think of to the existing solution is to make more Circle apps available. I've created a workstation issue for that and will see if we can get any volunteers: https://pagure.io/fedora-workstation/issue/330

Leave the current solution in place until there's an alternative?

Comment 8 Milan Crha 2022-08-26 09:42:12 UTC
(In reply to Allan Day from comment #7)
> Leave the current solution in place until there's an alternative?

Agreed.


Note You need to log in before you can comment on or make changes to this bug.