Bug 211957 - top goes into hard loop on xterm exit
top goes into hard loop on xterm exit
Status: CLOSED DUPLICATE of bug 211956
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: procps (Show other bugs)
4.4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-24 00:23 EDT by Major
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-24 06:17:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Major 2006-10-24 00:23:10 EDT
Description of problem:
top run as root goes into hard loop if the xterm it is running under exits

Version-Release number of selected component (if applicable):
procps-3.2.3-8.4

How reproducible:
100%

Steps to Reproduce:
1. Start an xterm
2. su to root
3. run top
4. kill the xterm
  
Actual results:
top process goes into hard loop consuming 100% of available cpu

Expected results:
top process terminates

Additional info:
Comment 1 Karel Zak 2006-10-24 06:17:13 EDT

*** This bug has been marked as a duplicate of 211956 ***

Note You need to log in before you can comment on or make changes to this bug.