Bug 2119796 - F37FailsToInstall: seahorse-nautilus
Summary: F37FailsToInstall: seahorse-nautilus
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: seahorse-nautilus
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2126510 (view as bug list)
Depends On:
Blocks: F37FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2022-08-19 12:49 UTC by Miro Hrončok
Modified: 2022-09-16 00:16 UTC (History)
4 users (show)

Fixed In Version: seahorse-nautilus-3.11.92-22.20220906git2cc2a06.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-16 00:16:56 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2022-08-19 12:49:01 UTC
Hello,

Please note that this comment was generated automatically. If you feel that this output has mistakes, please contact me via email (mhroncok).

Your package (seahorse-nautilus) Fails To Install in Fedora 37:

can't install seahorse-nautilus:
  - nothing provides libnautilus-extension.so.1()(64bit) needed by seahorse-nautilus-3.11.92-20.fc36.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-37-x86_64 --config-opts mirrored=False install seahorse-nautilus


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2022-08-29 10:42:41 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 2 Miro Hrončok 2022-09-13 16:53:21 UTC
*** Bug 2126510 has been marked as a duplicate of this bug. ***

Comment 3 bugzillllllaaaaaa 2022-09-14 17:57:32 UTC
after removing the seahorse-nautilus i can actually able to install the upgrade
```
$ sudo dnf system-upgrade download --releasever 37
Before you continue ensure that your system is fully upgraded by running "dnf --refresh upgrade". Do you want to continue [y/N]: y
Copr repo for PyCharm owned by phracek          4.0 kB/s | 3.6 kB     00:00    
Fedora 37 - x86_64                               26 kB/s |  25 kB     00:00    
Fedora 37 - x86_64                              109 kB/s | 1.7 MB     00:15    
Fedora 37 openh264 (From Cisco) - x86_64        1.2 kB/s | 989  B     00:00    
Fedora Modular 37 - x86_64                      8.1 kB/s | 5.0 kB     00:00    
Fedora Modular 37 - x86_64                       70 kB/s | 174 kB     00:02    
Fedora 37 - x86_64 - Updates                    4.2 kB/s | 4.9 kB     00:01    
Fedora Modular 37 - x86_64 - Updates            4.2 kB/s | 4.8 kB     00:01    
google-chrome                                   4.3 kB/s | 1.3 kB     00:00    
RPM Fusion for Fedora 37 - Nonfree - NVIDIA Dri 2.8 kB/s | 2.0 kB     00:00    
RPM Fusion for Fedora 37 - Nonfree - Steam      2.0 kB/s | 2.0 kB     00:00    
no group 'arm-tools' from environment 'workstation-product-environment'
No match for group package "authselect-compat"
No match for group package "reiserfs-utils"
No match for group package "kanjistrokeorders-fonts"
No match for group package "google-noto-sans-anatolian-hieroglyphs-vf-fonts"
No match for group package "google-noto-sans-buhid-vf-fonts"
No match for group package "google-noto-sans-imperial-aramaic-vf-fonts"
No match for group package "google-noto-sans-mayan-numerals-vf-fonts"
No match for group package "google-noto-sans-warang-citi-vf-fonts"
No match for group package "google-noto-sans-shavian-vf-fonts"
No match for group package "google-noto-sans-lydian-vf-fonts"
No match for group package "google-noto-sans-takri-vf-fonts"
No match for group package "google-noto-sans-marchen-vf-fonts"
No match for group package "google-noto-sans-devanagari-ui-vf-fonts"
No match for group package "yanone-tagesschrift-fonts"
No match for group package "google-noto-sans-lao-looped-vf-fonts"
No match for group package "google-noto-sans-yi-vf-fonts"
No match for group package "google-noto-sans-gothic-vf-fonts"
No match for group package "xorg-x11-drv-armsoc"
No match for group package "google-noto-sans-egyptian-hieroglyphs-vf-fonts"
No match for group package "google-noto-sans-wancho-vf-fonts"
No match for group package "culmus-shofar-fonts"
No match for group package "drehatlas-warender-bibliothek-fonts"
No match for group package "google-noto-sans-deseret-vf-fonts"
No match for group package "google-noto-sans-cuneiform-vf-fonts"
No match for group package "google-noto-sans-buginese-vf-fonts"
No match for group package "google-noto-sans-mro-vf-fonts"
No match for group package "tlomt-junction-fonts"
No match for group package "google-noto-sans-vai-vf-fonts"
No match for group package "google-noto-sans-phoenician-vf-fonts"
No match for group package "qgnomeplatform"
No match for group package "google-noto-sans-linear-b-vf-fonts"
No match for group package "google-noto-sans-nabataean-vf-fonts"
No match for group package "google-noto-sans-linear-a-vf-fonts"
No match for group package "google-noto-sans-mandaic-vf-fonts"
No match for group package "google-noto-sans-elymaic-vf-fonts"
No match for group package "google-noto-sans-osmanya-vf-fonts"
No match for group package "google-noto-serif-tangut-vf-fonts"
No match for group package "google-noto-sans-ugaritic-vf-fonts"
No match for group package "google-noto-sans-lycian-vf-fonts"
No match for group package "google-noto-sans-cypriot-vf-fonts"
No match for group package "drehatlas-xaporho-fonts"
No match for group package "google-noto-sans-thai-looped-vf-fonts"
No match for group package "google-noto-sans-tagbanwa-vf-fonts"
No match for group package "bcm283x-firmware"
No match for group package "google-noto-sans-carian-vf-fonts"
No match for group package "vollkorn-fonts"
No match for group package "google-noto-sans-multani-vf-fonts"
No match for group package "google-noto-sans-hatran-vf-fonts"
No match for group package "polarsys-b612-sans-fonts"
No match for group package "ubuntu-title-fonts"
No match for group package "google-noto-sans-ogham-vf-fonts"
No match for group package "google-noto-sans-avestan-vf-fonts"
No match for group package "google-noto-sans-soyombo-vf-fonts"
Dependencies resolved.
================================================================================
 Package                            Arch   Version                 Repo    Size
================================================================================
Installing:
 kernel                             x86_64 5.19.8-300.fc37         fedora 262 k
~and so on
```

Comment 4 bugzillllllaaaaaa 2022-09-14 17:58:46 UTC
$ sudo dnf remove seahorse-nautilus
Dependencies resolved.
================================================================================
 Package                Arch        Version                 Repository     Size
================================================================================
Removing:
 seahorse-nautilus      x86_64      3.11.92-20.fc36         @fedora       847 k
Removing unused dependencies:
 libcryptui             x86_64      3.12.2-26.fc36          @updates      4.2 M

Transaction Summary
================================================================================
Remove  2 Packages

Freed space: 5.0 M
Is this ok [y/N]: y
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Erasing          : seahorse-nautilus-3.11.92-20.fc36.x86_64               1/2 
  Erasing          : libcryptui-3.12.2-26.fc36.x86_64                       2/2 
  Running scriptlet: libcryptui-3.12.2-26.fc36.x86_64                       2/2 
  Verifying        : libcryptui-3.12.2-26.fc36.x86_64                       1/2 
  Verifying        : seahorse-nautilus-3.11.92-20.fc36.x86_64               2/2 

Removed:
  libcryptui-3.12.2-26.fc36.x86_64   seahorse-nautilus-3.11.92-20.fc36.x86_64  

Complete!

Comment 5 Kalev Lember 2022-09-14 18:40:37 UTC
Looks like upstream has just finished porting seahorse-nautilus to nautilus 43, so I went ahead and updated the Fedora package to an upstream git snapshot.

Comment 6 Fedora Update System 2022-09-14 18:51:30 UTC
FEDORA-2022-5d2dea3270 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-5d2dea3270

Comment 7 Fedora Update System 2022-09-15 01:49:11 UTC
FEDORA-2022-5d2dea3270 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2022-5d2dea3270`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-5d2dea3270

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2022-09-16 00:16:56 UTC
FEDORA-2022-5d2dea3270 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.