Bug 21201 - Problem with Oracle and Web importing foreign characters
Problem with Oracle and Web importing foreign characters
Status: CLOSED CURRENTRELEASE
Product: Red Hat Web Site
Classification: Red Hat
Component: Store (Show other bugs)
current
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin C. Messer
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-21 15:41 EST by Jeffrey Cohen
Modified: 2015-01-07 18:42 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-22 13:05:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeffrey Cohen 2000-11-21 15:41:19 EST
There seems to be a recurrance of foreign characters not importing properly
from the web into Oracle.

The following order: 3111741 from web order W2200617 imported with the
Customer name:

"SVERRIR C LAFSSON"  it should have been "...OLAFFSON"  

I beleive there was an O with an 'umlaut'  (the 2 little dots above a
letter) in the original customer name and somewhere along the line, an
interface corrupted this value to an invalid
character --(a square block)-- in the name field.

Can this be fixed???
Comment 1 Jeffrey Cohen 2000-11-21 15:44:55 EST
I have since changed the information, Customer Name and Contact name on Account
# 274263.

I just over-typed the correct information, hopefully deleting the corrupted
character.  Hopefully the order will go now.

-Jeff

Comment 2 Samir Kothari 2000-11-21 16:44:35 EST
If you look at the web_user_personal_info table for this user (464319), you
will see the following:

C-rlafsson

When I cut-n-paste into the bugzilla screen it converts it to:

Crlafsson

It appears to be getting imported into oracle as the 1st case above.

Comment 3 Jeffrey Cohen 2000-12-14 08:17:18 EST
Here is yet another example of corrupted characters...

 His proper name should be: Mindez Guido Josi Angel

-Jeff

Customer information

                                   Information for customer: mguido-RH2000 
            User ID
                                 mguido-RH2000
            Password
                                 RH24636rh
            First name
                                 Guido Josgngel
            Last name
                                 Mh-$ez
            e-mail
                                 mguido@inwind.it
Comment 4 Jay Turner 2001-05-15 08:50:08 EDT
Status update on this issue?  Thanks :-)
Comment 5 Tom Lancaster 2001-05-21 19:08:51 EDT
According to the Oracle reference: "All character data in the version 8 database
is assumed to be in the character encoding scheme specified in the CREATE
DATABASE command that created the database."
I really don't know what this is. 
The NLS LANG variable also has something to do with it. I seem to remember Paul
Lindner saying that the web tables supported UTF8, which should be able to deal
with the above cases. 
Comment 6 Martin C. Messer 2003-07-22 13:05:53 EDT
Dealing with this same issue elsewhere.

Note You need to log in before you can comment on or make changes to this bug.