Bug 212048 - desktop-file-install failing on valid categories
Summary: desktop-file-install failing on valid categories
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: desktop-file-utils (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-24 19:26 UTC by Chris Lumens
Modified: 2008-01-18 17:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 17:25:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Lumens 2006-10-24 19:26:53 UTC
The system-config-kickstart spec file has the following chunk in it:

desktop-file-install --vendor system --delete-original      \
  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
  --add-category Application \
  --add-category System \
  --add-category X-Red-Hat-Base          \
  $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop

This fails to build in a devel build root because of the following error messages:

 + desktop-file-install --vendor system --delete-original --dir
/var/tmp/system-config-kickstart-2.6.15-root/usr/share/applications
--add-category Application --add-category System --add-category X-Red-Hat-Base
/var/tmp/system-config-kickstart-2.6.15-root/usr/share/applications/system-config-kickstart.desktop
/var/tmp/system-config-kickstart-2.6.15-root/usr/share/applications/system-config-kickstart.desktop:
missing encoding  (guessed UTF-8)
/var/tmp/system-config-kickstart-2.6.15-root/usr/share/applications/system-config-kickstart.desktop:
error: Categories values must be one of "Core", "Development", "Building",
"Debugger", "IDE", "GUIDesigner", "Profiling", "RevisionControl", "Translation",
"Office", "Calendar", "ContactManagement", "Database", "Dictionary", "Chart",
"Email", "Finance", "FlowChart", "PDA", "ProjectManagement", "Presentation",
"Spreadsheet", "WordProcessor", "Graphics", "2DGraphics", "VectorGraphics",
"RasterGraphics", "3DGraphics", "Scanning", "OCR", "Photography", "Viewer",
"Settings", "DesktopSettings", "HardwareSettings", "PackageManager", "Network",
"Dialup", "InstantMessaging", "IRCClient", "FileTransfer", "HamRadio", "News",
"P2P", "RemoteAccess", "Telephony", "WebBrowser", "WebDevelopment",
"AudioVideo", "Audio", "Midi", "Mixer", "Sequencer", "Tuner", "Video", "TV",
"AudioVideoEditing", "Player", "Recorder", "DiscBurning", "Game", "ActionGame",
"AdventureGame", "ArcadeGame", "BoardGame", "BlocksGame", "CardGame",
"KidsGame", "LogicGame", "RolePlaying", "Simulation", "SportsGame",
"StrategyGame", "Education", "Art", "Construction", "Music", "Languages",
"Science", "Astronomy", "Biology", "Chemistry", "Geology", "Math",
"MedicalSoftware", "Physics", "Teaching", "Amusement", "Applet", "Archiving",
"Electronics", "Emulator", "Engineering", "FileManager", "Shell", "ScreenSaver",
"TeminalEmulator", "TrayIcon", "System", "Filesystem", "Monitor", "Security",
"Utility", "Accessibility", "Calculator", "Clock", "TextEditor", "KDE", "GNOME",
"GTK", "Qt", "Motif", "Java", "ConsoleOnly" (found "X-Red-Hat-Base")
/var/tmp/system-config-kickstart-2.6.15-root/usr/share/applications/system-config-kickstart.desktop:
error: Categories values must be one of "Core", "Development", "Building",
"Debugger", "IDE", "GUIDesigner", "Profiling", "RevisionControl", "Translation",
"Office", "Calendar", "ContactManagement", "Database", "Dictionary", "Chart",
"Email", "Finance", "FlowChart", "PDA", "ProjectManagement", "Presentation",
"Spreadsheet", "WordProcessor", "Graphics", "2DGraphics", "VectorGraphics",
"RasterGraphics", "3DGraphics", "Scanning", "OCR", "Photography", "Viewer",
"Settings", "DesktopSettings", "HardwareSettings", "PackageManager", "Network",
"Dialup", "InstantMessaging", "IRCClient", "FileTransfer", "HamRadio", "News",
"P2P", "RemoteAccess", "Telephony", "WebBrowser", "WebDevelopment",
"AudioVideo", "Audio", "Midi", "Mixer", "Sequencer", "Tuner", "Video", "TV",
"AudioVideoEditing", "Player", "Recorder", "DiscBurning", "Game", "ActionGame",
"AdventureGame", "ArcadeGame", "BoardGame", "BlocksGame", "CardGame",
"KidsGame", "LogicGame", "RolePlaying", "Simulation", "SportsGame",
"StrategyGame", "Education", "Art", "Construction", "Music", "Languages",
"Science", "Astronomy", "Biology", "Chemistry", "Geology", "Math",
"MedicalSoftware", "Physics", "Teaching", "Amusement", "Applet", "Archiving",
"Electronics", "Emulator", "Engineering", "FileManager", "Shell", "ScreenSaver",
"TeminalEmulator", "TrayIcon", "System", "Filesystem", "Monitor", "Security",
"Utility", "Accessibility", "Calculator", "Clock", "TextEditor", "KDE", "GNOME",
"GTK", "Qt", "Motif", "Java", "ConsoleOnly" (found "Application")
desktop-file-install created an invalid desktop file!

This same build works on a RHEL5 build root.

Comment 1 Ray Strode [halfline] 2006-10-24 19:35:20 UTC
So first off, we have to either get Application added to the spec or change it
to X-Application (and update our .menu files).  Also we have to make
desktop-file-install not choke on categories that start with X-

Comment 2 Matthias Clasen 2006-10-25 04:15:41 UTC
I believe "Application" would be a bit redundant, since all the desktop files
that are relevant for menus should have Type=Application anyway.

Another thing that the validator may want to check is the main/additional category
distinction made in the menu spec.

Comment 3 Nils Philippsen 2006-10-26 07:33:34 UTC
It barfed on me too, with "Application" (which I'm going to remove if that's
intentionally not valid), "X-Fedora" and "X-Red-Hat-Base". Does it already know
(again) about the "X-" category exception? I'd like to be able to build again ;-).

Comment 4 Tim Waugh 2006-10-27 17:31:36 UTC
Adding myself to CC since this is preventing builds.

Comment 5 Ray Strode [halfline] 2006-10-27 19:18:33 UTC
I commited a workaround for now to get builds going again.

Comment 6 Chris Lumens 2008-01-18 17:25:34 UTC
Haven't had any problems here for a long while.


Note You need to log in before you can comment on or make changes to this bug.