Bug 212100 - pup metadata appears clickable, but is not
Summary: pup metadata appears clickable, but is not
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Luke Macken
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-25 02:02 UTC by Bill Nottingham
Modified: 2016-09-20 02:37 UTC (History)
3 users (show)

Fixed In Version: 1.2.9-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 15:04:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2006-10-25 02:02:51 UTC
Description of problem:

The 'Bugs' and 'CVE' entries in the metadata display appear to
be clickable, but they are not.

Version-Release number of selected component (if applicable):

pirut-1.2.5-1

Comment 1 Luke Macken 2006-10-25 16:44:36 UTC
Clicking on the links opens them in my browser just fine, it's just that the
mouse cursor does not change when you hover over them.  In any case, this is a
known issue and needs to be fixed.

        # FIXME: figure out why this event only gets called when your cursor

        # enters and leaves the TextView (making it impossible to change the

        # cursor when hovering over a link)

        self.details.connect("motion-notify-event",

                             UpdateDetails.motion_notify_event)


Since this only gets called when entering/leaving the details text view, there
is no way to detect link hovering.  We either need to find a callback that gets
fired off when moving around the view, or change the update details to something
other than a hacked-out GtkTextView.

Comment 2 Bill Nottingham 2006-10-25 17:15:13 UTC
Now that I think about it, the clicking probably didn't work b/c I was running
pirut remotely.

Comment 3 Luke Macken 2007-04-25 15:04:20 UTC
I disabled the links in the update details a while ago due to pup launching
firefox as root (if an instance isn't already open) (Bug #216552).  So this bug
is "resolved" until we figure out a way to safely link to bugs/cves.


Note You need to log in before you can comment on or make changes to this bug.