Bug 212102 - linux-iscsi ISCSI_MAX_CMDS_PER_LUN should be larger to allow for perf tuning
linux-iscsi ISCSI_MAX_CMDS_PER_LUN should be larger to allow for perf tuning
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike Christie
Brian Brock
: FutureFeature
Depends On: 181787
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-24 23:14 EDT by Dave Wysochanski
Modified: 2009-11-10 13:34 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 13:34:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Dave Wysochanski 2006-10-24 23:21:18 EDT
Might be too late for RHEL5 but perhaps changing the max #define isn't out of
the question. (Sanjay Gulabani at netapp asked for this -
Sanjay.Gulabani@netapp.com)

Here's the thread earlier this year with a patch that never got in upstream:
http://tinyurl.com/wynfp

Maybe we can resurrect something like that for upstream and long-term.
Comment 2 Dave Wysochanski 2006-10-25 09:18:43 EDT
Ok I looked at the code in more detail and remember that it's probably not so
easy to change the #define because of the structures we allocate based on these
max values.

I was going to reassign this to myself but it doesn't look like I can change the
assignment field.
Comment 4 Ernie Petrides 2007-09-05 18:00:38 EDT
Reassigning to DaveW based on comment #2.

Please fix the bug summary to contain something that can be found in
the RHEL5 kernel source tree.  ISCSI_MAX_CMDS_PER_LUN does not exist,
and the place in RHEL4 where its use was converted to iscsi_cmds_per_lun,
which was in the function iscsi_slave_configure(), doesn't exist in RHEL5.
Comment 5 Mike Christie 2007-09-05 18:12:10 EDT
Dave I can take this one if you want. It is all upstream in the open-iscsi git
tree so it just requires a backport. I did not port this part in my 5.1 update
because I did not have time to test the KABI and ABI workarounds that are needed
to port upstream to RHEL.
Comment 6 Dave Wysochanski 2007-09-05 18:21:37 EDT
Ok thanks - I am sure it would take me much longer to get it right.
Comment 7 Mike Christie 2009-11-10 13:34:34 EST
This was fixed in RHEL 5.2 or RHEL 5.3. Closing bug.

Note You need to log in before you can comment on or make changes to this bug.