Bug 212107 - autogen needs to be rebuilt
autogen needs to be rebuilt
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: autogen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-25 00:00 EDT by Seth Vidal
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 5.8.7-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-26 17:55:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Seth Vidal 2006-10-25 00:00:26 EDT
autogen in FC6 needs to be rebuilt to pickup the libopts.so.25 in libopts now in
fc6.
Comment 1 Seth Vidal 2006-10-25 00:14:50 EDT
I am wrong. i just rebuilt it locally. It looks like it is pulling in some sort
of internal libopts dep from the version of libopts it carries around internally.

needs to be fixed so you can install anjuta.
Comment 2 Michael Cronenworth 2006-10-25 11:40:54 EDT
I can confirm this issue. yum install anjuta fails with unresolved dependency in
autogen. I had to uninstall anjuta when upgrading from FC5->FC6 to use yum.
Comment 3 Seth Vidal 2006-10-25 11:42:36 EDT
Yah. I had to do the same thing. It broke my heart.
Comment 4 Robert Hollencamp 2006-10-26 10:58:00 EDT
I was able to install anjuta without a problem but could not start a project
because it said it was unable to find autogen. running autogen at the command
line yields

[root@rph5010 wizzard]# autogen
AutoGen aborting on signal 11 (Segmentation fault) in state OPTIONS
Aborted
Comment 5 Paul F. Johnson 2006-10-26 11:28:09 EDT
Which version of FC are you running. I'm not seeing anything untoward at this end.
Comment 6 Robert Hollencamp 2006-10-26 13:27:43 EDT
Just did a fresh install of FC 6 from the dvd
Comment 7 Paul F. Johnson 2006-10-26 14:53:41 EDT
Run yum update - there is a fresh version of autogen available.
Comment 8 Michael Cronenworth 2006-10-26 17:44:16 EDT
Thanks Paul. The new autogen+libopts RPMs fixed it, although now I'm seeing some
Anjuta bugs... might be time to search/create a new bug.

Why was this single file split from autogen? Autogen has one file and libopts
has one file when it used to be one package with two files... do we need
packages with just one file in them??
Comment 9 Paul F. Johnson 2006-10-26 17:55:35 EDT
If you'd file the anjuta bugs apart from this BZ, I'd appreciate it.

There is a long history behind libopts and autogen. Basically, they used to be
apart, then they came together but libopts was already a package, so it made
some sense to keep them apart.

I think I'll look into bringing them together.

Note You need to log in before you can comment on or make changes to this bug.