Bug 212120 - Muine crashes on importing of folder
Muine crashes on importing of folder
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: muine (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Sindre Pedersen Bjørdal
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: FE7Target
  Show dependency treegraph
 
Reported: 2006-10-25 03:51 EDT by Daniel Malmgren
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-23 09:10:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Malmgren 2006-10-25 03:51:47 EDT
Description of problem:
When I try to import a folder of music into Muine it crashes.

Version-Release number of selected component (if applicable):
Everything is Fedora devel up2date:
muine-0.8.5-7.fc6
mono-core-1.1.17.1-3.fc6
libglade2-2.6.0-2

How reproducible:
100%

Steps to Reproduce:
1. Start Muine
2. file->import folder
3. Choose any directory
4. Click OK
  
Actual results:
Unhandled Exception: Glade.HandlerNotFoundException: The handler for the event
Response should take '(System.Object,Gtk.ResponseArgs)', but the signature of
the provided handler ('OnWindowResponse') is '(System.Object,System.EventArgs)'

at SignalConnector.ConnectFunc (intptr,intptr,intptr,intptr,intptr,int,intptr)
<0x004b3>
at (wrapper native-to-managed) SignalConnector.ConnectFunc
(intptr,intptr,intptr,intptr,intptr,int,intptr) <0x0008f>
in (unmanaged) 0x368d2097e5
at (wrapper managed-to-native) SignalConnector.glade_xml_signal_autoconnect_full
(intptr,Glade.XML/SignalConnector/RawXMLConnectFunc,intptr) <0x0000e>
at SignalConnector.Autoconnect () <0x0006f>
at Glade.XML.Autoconnect (object) <0x00058>
at Muine.ProgressWindow..ctor (Gtk.Window) <0x00061>
at AddFoldersThread..ctor (System.Collections.ArrayList) <0x0008c>
at Muine.SongDatabase.AddWatchedFolders (System.Collections.ArrayList) <0x0026b>
at Muine.ImportDialog.OnResponse (object,Gtk.ResponseArgs) <0x001f3>
at (wrapper delegate-invoke)
System.MulticastDelegate.invoke_void_object_ResponseArgs
(object,Gtk.ResponseArgs) <0x00063>
at Gtk.Dialog.ResponseSignalCallback (intptr,int,intptr) <0x0015f>
at (wrapper native-to-managed) Gtk.Dialog.ResponseSignalCallback
(intptr,int,intptr) <0x00057>
in (unmanaged) 0x367dc0b169
at (wrapper managed-to-native) Gtk.Application.gtk_main () <0x0000b>
at Gtk.Application.Run () <0x00008>
at Muine.Global.Main (string[]) <0x00794>

Additional info:
I'm not quite sure, but it seems like the files in the directory did get
imported into Muine anyways, since they pop up in the songlist now. They might
have been there in before as well though, I never checked...
Comment 1 Thilo Pfennig 2006-10-28 16:42:14 EDT
yes, 100% same here. crash but folder gets imported
Comment 2 Austin Jackson 2006-11-14 19:40:56 EST
yep, same here.
Comment 3 Daniel Malmgren 2007-05-25 03:02:39 EDT
Since this bug never got any attention whatsoever I guess it's not worth having
open anymore. I don't even use Muine anymore...
Comment 4 Michael Schwendt 2007-05-25 03:43:14 EDT
So, is it a bug or isn't it?
Comment 5 Daniel Malmgren 2007-05-25 03:49:27 EDT
I guess it is a bug. I have no idea though if it's fixed long ago or works,
since I don't use Muine anymore. A bug that I don't know if it's still there and
that nobody seems to care about fixing doesn't seem of much use to me...

Note You need to log in before you can comment on or make changes to this bug.