Bug 212125 - yum crash at startup on FC5 live upgrade
yum crash at startup on FC5 live upgrade
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-25 04:10 EDT by Guillaume Bougard
Modified: 2014-01-21 17:55 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 14:33:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Console output with the traceback (1.77 KB, text/plain)
2006-10-25 04:10 EDT, Guillaume Bougard
no flags Details

  None (edit)
Description Guillaume Bougard 2006-10-25 04:10:01 EDT
Description of problem:
 * Trying to upgrade an x86_64 FC5 system to FC6
 * After preliminary update yum crashed during initialization on an "yum update"

Version-Release number of selected component (if applicable):
 * yum-3.0-6

How reproducible:
 * Upgrade a FC-5 system with:
   * yum (don't know what version it was as it has been just updated)
   * yum-protectbase-0.6-3.fc5
   * yum-fastestmirror-0.6-3.fc5
   * yum-kernel-module-0.6-3.fc5
   * yum-fedorakmod-0.6-3.fc5
   * yum-changelog-0.6-3.fc5

Steps to Reproduce:
1. Upgrade fedora-release to 6-4 and fedora-release-notes to 6-3
2. Update yum with 'yum update yum':
   yum updated to 3.0-6
   yum-metadata-parser installed to 1.0-8.fc6
3. Now try to update all the system with 'yum update'
4. See yum traceback
  
Actual results:
 * Traceback returns instead of processing updates

Expected results:
 * Update process begins


Additional info:
 * Before I update yum I tried directly a 'yum update' that started as expected
by downloading packages headers. I aborted the process (ctrl-C) thinking I
should update yum before update all the system. Then I hit that error.
Comment 1 Guillaume Bougard 2006-10-25 04:10:01 EDT
Created attachment 139314 [details]
Console output with the traceback
Comment 2 Guillaume Bougard 2006-10-25 04:13:58 EDT
Problem resolved by removing the package yum-fastestmirror with:
rpm -e yum-fastestmirror-0.6-3.fc5
Comment 3 Guillaume Bougard 2006-10-25 04:37:42 EDT
I found the yum installed version in /var/log/yum.log logs:
/var/log/yum.log.2:May 10 12:53:27 (yumex) Updated: yum.noarch 2.6.1-0.fc5
Comment 4 Seth Vidal 2006-10-25 08:49:28 EDT
adding luke so he can see it
Comment 5 Bill Nottingham 2006-10-25 12:17:19 EDT
Should we change the 'upgrade with yum' directions to 'yum upgrade yum*'?
Comment 6 Luke Macken 2006-10-25 12:30:15 EDT
The FC5 version of yum-fastestmirror will not work with the FC6 version of yum
due to API changes.  Removing and re-installing yum-fastestmirror should resolve
this issue.

(In reply to comment #5)
> Should we change the 'upgrade with yum' directions to 'yum upgrade yum*'?

This sounds like a good idea.


Note You need to log in before you can comment on or make changes to this bug.