Bug 21218 - [errata glibc]: /usr/share owned by this package
Summary: [errata glibc]: /usr/share owned by this package
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-22 02:27 UTC by Enrico Scholz
Modified: 2016-11-24 15:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-22 17:07:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2000-11-22 02:27:46 UTC
/usr/share is being owned by glibc:

$ rpm -qlp -vv glibc-2.2-5.fixarch.i686.rpm
...
drwxr-xr-x    1 root    root             4096 Nov 22 02:39 /usr/share


(Because rpm is buggy, cpio will fail if /usr/shared is %netshared and
mounted ro. So installation of glibc gets incomplete)

No other package (except filesystem) owns /usr/share so it seems to be a
bug in glibc.

I think the statement
-----------------
for n in %{_prefix}/share %{_prefix}/include %{_prefix}/lib/locale; do 
    find ${RPM_BUILD_ROOT}${n} -type d | \
        grep -v '^%{_prefix}/share$' | \
        sed "s/^/%dir /" >> rpm.filelist.in
done
-----------------

in glibc.spec is wrong. You are grep'ping for directories *beginning* (^)
with /usr/share, but
`find' returns $RPM_BUILD_ROOT/usr/share.

Comment 1 Jakub Jelinek 2000-11-22 17:07:55 UTC
Fixed in our CVS, but will appear only in 7.1 or if we'll be doing another
errata for some reason some day. E.g. glibc-2.1.2-15 owns /usr/share because
of this as well.

Comment 2 Jakub Jelinek 2000-12-18 22:39:28 UTC
This is in glibc-2.2-9.


Note You need to log in before you can comment on or make changes to this bug.