Bug 212189 - mkdumprd has obsolete codes
Summary: mkdumprd has obsolete codes
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kexec-tools   
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Neil Horman
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-25 15:43 UTC by Akira Imamura
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-13 17:18:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Akira Imamura 2006-10-25 15:43:26 UTC
Description of problem:
mkdumprd has obsolete codes. Although finddmmods() returns 1 in some
cases, there's nowhere to review any return values.


Version-Release number of selected component (if applicable):
kexec-tools-1.101-106.el5

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Neil Horman 2006-10-26 13:24:47 UTC
There are some outstanding questions regarding the usefullnes of this code, and
the resolution we should take with it (removal vs. fixing to work properly), 
The code exists in this state in mkinitrd as well.  I've found where the modules
usually handled by finddmmods are now being picked up, and am discussing with
pjones the best way to handle this particular piece of code.

Comment 2 Neil Horman 2006-11-01 18:27:55 UTC
fixed in -116.el5

Comment 3 Akira Imamura 2006-11-01 19:30:04 UTC
I reviewed the latest script of mkdumprd, but I don't know how you
fixed it. What has changed in it?


Comment 4 Neil Horman 2006-11-01 19:37:01 UTC
sorry, that should have read -117.el5

Comment 5 Jay Turner 2007-02-13 17:18:00 UTC
kexec-tools-1.101-164.el5 included in 20070208.0.


Note You need to log in before you can comment on or make changes to this bug.