Bug 2122 - Install with multiple CD players broken
Summary: Install with multiple CD players broken
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-11 13:13 UTC by Chris Ricker
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-09-25 03:48:10 UTC


Attachments (Terms of Use)

Description Chris Ricker 1999-04-11 13:13:41 UTC
<I'm re-entering this here, since stuff posted on the
mailing list doesn't seem to wind up here>

If you have two CD players in the same machine, the
installer looks in the first one found by the kernel
for media, and then quits.  It should instead look
in all of the kernel-reported CD players sequentially
(and if it does this, have the user confirm that that's
the desired device) or else just ask the user immediately
which CD player to use if multiple devices are reported.

later,
chris

Comment 1 Preston Brown 1999-04-12 20:06:59 UTC
for later, obviously. :)

Comment 2 Matt Wilson 1999-04-13 18:20:59 UTC
Will be fixed later.

Comment 3 Jay Turner 1999-07-07 16:45:59 UTC
*** Bug 3492 has been marked as a duplicate of this bug. ***

The installer appears to be only capable of installing from
/dev/hdc.  My /dev/hdc is a first generation dvdrom; it
doesn't read cds.  My /dev/hdd is a cdrom, and reads much
faster to boot.  Historically, on my system, to install
redhat linux I've had to unplug my dvdrom to install, which
is really a pain.  Users should get a choice of what device
to use, or at least be able to specify some option to the
installer.

------- Additional Comments From jturner@redhat.com  06/16/99 14:40 -------
This issue has been forwarded to the install developer for further
consideration.

Comment 4 Bill Nottingham 1999-09-25 03:48:59 UTC
This is fixed in the latest installer in Raw Hide. It tries
all CD-ROMs.


Note You need to log in before you can comment on or make changes to this bug.