Bug 21220 - Problem with Video card operating with Xservers
Problem with Video card operating with Xservers
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2000-11-21 22:10 EST by Gavin S. Roberts
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-12-04 05:49:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gavin S. Roberts 2000-11-21 22:10:18 EST
Note: The computer that this is experiencing problems with is A Compaq 
(eww) Presario 1600XL series laptop that carries the Trident Cyberblade i1 
AGP (51) graphics card (chipset unknown) and, superprobe tells me that I 
need to select a ramdac ->(Sierra SC11482{2,3,4} or Sierra SC1148).
Signature data from superprobe was 85201023.
Card RAM is approx 2 (3.5)M. 

There have been about thirty setup attempts now on my part to configure 
the GUI's and graphical applications to operate on the Accel servers, SVGA 
server, VGA2/VGA16 server, and MONO server.  All attempts save one have 

The attempt that worked was by attempting to setup VGA and once the 
GENERIC SETUP for a VGA monitor was selected the xwindows environment 
loaded at a resoulution that displayed the environmet at 3 -4 times the 
screen size, and the ctrl-alt-+ option did nothing to affect resolution.

ALL Attempts to use xf86_SVGA server have failed.  X windows response was 
that : No valid modes availiable.

All Attempts to use xf86_MONO server failed as well in the same manner.  
The Accel servers failed as expected.  

My primary report is that the Trident Cyberblade (generic) card selection 
does not (obviously) support this particular Cyberblade i1.  

I have been unable to find a fix, update or otherwise helpful information 
for this problem but have come across NUMEROUS frustrated would-be linux 
users whom cannot use it because of this same problem.

note: Would-be users reportedly ALL use the same make and model of compaq 
laptop that this problem persists on.

Seeking technical advice/assistance.
Comment 1 Need Real Name 2000-11-27 23:24:25 EST
Problem has been solved by the release of XFree86 Version 4.0.1 which uses a 
driver for all verions of Trident's graphic cards.
The driver is called "trident" and is availiable with the download from 
Comment 2 Mike A. Harris 2001-03-13 22:35:57 EST
Please try using XFree86 4.0.x which has better support for this
card.  You can get 4.0.2 packages from rawhide, or rebuild from source.

Note You need to log in before you can comment on or make changes to this bug.