Bug 212221 - Graphical Installer can't unmount DVD after partitioning
Graphical Installer can't unmount DVD after partitioning
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Depends On:
  Show dependency treegraph
Reported: 2006-10-25 14:28 EDT by Matthew
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-11 23:55:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Matthew 2006-10-25 14:28:53 EDT
Description of problem:
After selecting my install partitian to install, I get that they CD can't be
unount from /dev/source (or was it /mnt/source?) and it warns about using it
with tty2. I didn't do anything with tty2 and I rebooted to try it again and got
the same problem. I tried manually unounting /(dev/mnt)/source which I could do,
but the retry button still failed to work. The log window (tty3 I believe) said
something about cdmount (cdSOMETHING) illegal paramater. This wasn't a problem
once I switched to the text mode installer on reboot. The only oddity I can
think of is my LVM raid of two SATA drives?

AMD X2 3800+
NForce4 Pro
2GB Ram

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:
Comment 1 Steve Cobrin 2006-10-26 10:53:58 EDT
I have a similar problem. When I get to the screen to select what software to
install, I selected Fedora Extras then selected next. I then receive the message
"An error occured unmounting the CD. Please make sure you'r not accessing
/mnt/source from the shell on tty2 then vlick OK to retry." However I select OK
and get that message again, the is no way to proceed.

Further remarks:
- I'm booting of a DVD
- When I switch to tty2 and type mount, it tells me /tmp/cdrom is mounted on
/mnt/source I'm unable to umount either /mnt/source or /tmp/cdrom
"umount: Couldn't umount /tmp/cdrom: Function not implemented"
typing "eject" didn't work either
- In /tmp/anaconda.log the only relevant message appears to be
"ERROR: exception in unmountCD:( 16, 'Device or resource busy')
- When I typed "fuser /tmp/cdrom" I got a segmenattion fault
Comment 2 Steve Cobrin 2006-10-27 06:31:04 EDT
When I ran again, this time not selecting "Fedora Extras" it all worked and
didn't hang.
Comment 3 Matthew 2006-10-27 18:58:34 EDT
Just to confirm, Steve's situation is the same as mine.
Comment 4 Jeremy Katz 2006-10-30 14:14:36 EST
Can you provide /tmp/anaconda.log?
Comment 5 Red Hat Bugzilla 2007-06-11 23:21:04 EDT
requested by Jams Antill
Comment 6 Matthew 2007-06-11 23:55:06 EDT
This was against FC6 I believe, I no longer have this problem in F7 and I think
there isn't much interest in fixing this so change status to "WONTFIX"?

Note You need to log in before you can comment on or make changes to this bug.