Bug 212239 - RFE: use kde-window-decorator in KDE
Summary: RFE: use kde-window-decorator in KDE
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: F8Target
TreeView+ depends on / blocked
 
Reported: 2006-10-25 19:35 UTC by Chitlesh GOORAH
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version: 0.6.2-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-19 17:15:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chitlesh GOORAH 2006-10-25 19:35:17 UTC
Description of problem:
RFE 1:
It would be nice to have a feature which loads
        Load  "extmod"
in the section module of /etc/X11/corg.conf
Then It will remove the following error for the user:

compiz: No sync extension

RFE 2:
When deactivating desktop-effects, on kde, all opened applications get the
gnome-window-decorator. It would be better to have those opened applications
inherit kde's windows decorator.

Version-Release number of selected component (if applicable):
compiz-0.0.13-0.32.20060817git.fc6

How reproducible:
everytime

Comment 1 Chitlesh GOORAH 2006-11-10 21:14:12 UTC
Hello ?
It's been more that 3 weeks , any updates on either of these 2 RFE?

Comment 2 drago01 2007-02-15 18:25:55 UTC
compiz 0.3.6 has a kde-window-decorator but its not enabled by default because
it depends on dbus-qt which is in extras. with the extras/core merge it should
be no problem to build it.

Comment 3 Kristian Høgsberg 2007-02-16 17:28:57 UTC
No, the problem is that the dbus-qt bindings used by the kde-window-decorator
are not supported.  When someone updates the kde-window-decorator to use the
d-bus bindings that ship with qt4 we can look into enabling it.


Comment 4 Chitlesh GOORAH 2007-08-06 00:06:30 UTC
may I know the status of this bug ? should it be closed ?

Comment 5 Adam Jackson 2007-09-25 17:40:18 UTC
(In reply to comment #0)
> Description of problem:
> RFE 1:
> It would be nice to have a feature which loads
>         Load  "extmod"
> in the section module of /etc/X11/corg.conf
> Then It will remove the following error for the user:
> 
> compiz: No sync extension

extmod is loaded by default if there's no Module section.  Anything _adding_ a
module section, is broken.  The nvidia driver package in particular is guilty of
this.

Comment 6 Chitlesh GOORAH 2007-11-19 17:15:14 UTC
On F8, I have the KDE window decorator when compiz is enabled on KDE.
I'm satisfied and closing this bug.


Note You need to log in before you can comment on or make changes to this bug.