Bug 212260 - fc6 - xfs root fs fails on fresh install
fc6 - xfs root fs fails on fresh install
Status: CLOSED DUPLICATE of bug 212201
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
6
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Jones
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-25 17:10 EDT by stephen smart
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-15 18:22:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description stephen smart 2006-10-25 17:10:12 EDT
Description of problem: after installing fc6 dvd iso (both i386 and x86_64 -
both passed media check test and sha1sum), with xfs as root filesystem, system
fails to boot into OS, citing xfs errors.


Version-Release number of selected component (if applicable): 


How reproducible: extremely


Steps to Reproduce:
1. install using xfs filesystem
2. reboot
3. 
  
Actual results: after install using xfs as root filesystem. grub loads. kernel
loads. RH nash starts, lvm's found. "i/o error in filesystem ("dm-0") metadata
dev dm-0 block 0x770000000 ("xfs_trans_read_buf") error 5 buf count
4096"...fills screen until final lockup. tried xfs_repair which said bad
superblock and no good replacements.  drive works fine with fc4 and fc5 xfs as
root, also works fine with ext3 under fc6.


Expected results: fc6...


Additional info: all partitions removed before installation, drive works fine
under fc5 x86_64(both as xfs root, and as an xfs home dir). machine: tyan k8se
dual opteron 246,cheetah u160 scsi,adaptec u320 scsi,2gb hyperx ecc reg,geforce
7900 gtko - nothing overclocked. also tried dell inspiron 1100 notebook - same
results as below. no other partitions besides default ext2 boot, swap, and xfs
root. sorry if this is bad bug reporting - first time...
Comment 1 Chris Haidinyak 2006-10-27 00:02:32 EDT
I have the same problem. I tried on multiple SATA drives using sata_via with
multiple DVD burners. SHA1SUM was ok prior to burn. I use XFS as my primary
filesystem for "/"; not ext3. My computer set-up is x86_64 but the steps to
reproduce are the same as above.

Thanks,
  Chris Haidinyak
Comment 2 John Holmstadt 2006-10-27 10:27:16 EDT
This bug appears to be a dupe of 212201
Comment 3 Niels Basjes 2006-10-28 05:38:55 EDT
I have reproduced this problem twice using an install using PXE and HTTP on
1) A clean VMware server 'computer'.
2) A Toshiba laptop.

On both I got the same error messages as above when using XFS.
The only real difference is the block number that is presented.
Comment 4 Eric Sandeen 2006-11-15 18:22:05 EST

*** This bug has been marked as a duplicate of 212201 ***

Note You need to log in before you can comment on or make changes to this bug.