Bug 212267 - lvm'd multipath'd iscsi luns don't shutdown properly
lvm'd multipath'd iscsi luns don't shutdown properly
Status: CLOSED DUPLICATE of bug 212266
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-25 18:08 EDT by Josh Hildebrand
Modified: 2010-01-11 21:27 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-01 13:33:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Hildebrand 2006-10-25 18:08:18 EDT
Description of problem:
When a NetApp LUN is mounted via iscsi, and then device-mapper-multipath maps 
it to /dev/dm-#, and then lvm2 uses it as a physical device and subsequently 
in a logical volume and volume group, it seems to complicate the 
standard "shutdown -rf" reboot process.

I've taken a few snapshots of the console while my machine reboots in order to 
catch the errors.  But I'll do my best to retype them below.



Luckily, it doesn't HANG, but I do wonder how good it is on the 
data/filesystem of this LUN.


Version-Release number of selected component (if applicable):
device-mapper-multipath-0.4.5-16.1.RHEL4
iscsi-initiator-utils-4.0.3.0-4
lvm2-2.02.06-6.0.RHEL4
kernel-smp-2.6.9-42.0.3.EL

How reproducible:
Every time

Steps to Reproduce:
1. Mount up a Netapp LUN over iSCSI using multipath-dm
2. Add it to a LVM
3. shutdown -rf
  
Actual results:
Stopping multipathd daemon: device-mapper: waitevent ioctl failed: Interrupted 
system call
....
Searching for iscsi-based multipath maps
Found 1 maps
Flushing iscsi-based multipath map, mpath60
mpath60: map in use     (I imagine because of LVM)
Stopping iscsid:            [OK]
iscsi-sfnet:host1: Session dropped
iscsi-sfnet:host2: Session dropped
iscsi-sfnet:host3: Session dropped
iscsi-sfnet:host4: Session dropped
Removing iscsi driver: ERROR: Module iscsi_sfnet is in use   [FAILED]
.....
(i may have missed something important here)
....
scsi4 (0:9): rejecting I/O to dead device
device-mapper: dm-multipath: Failing path 8:32.
scsi3 (0:9): rejecting I/O to dead device
device-mapper: dm-multipath: Failing path 8:16.
Buffer I/O error on device dm-1, logical blcok 13098993
Buffer I/O error on device dm-1, logical blcok 13098994
Buffer I/O error on device dm-1, logical blcok 13098995
....etc,etc...
Restarting system.

Expected results:
A good clean shutdown, w/o all the warnings.

Additional info:
I haven't tested this scenario W/O lvm2 being involved.
Comment 1 Josh Hildebrand 2006-10-25 18:13:30 EDT
sorry about the duplicate of 212265.. i kept getting this error after 
resubmitting it:

Invalid Product Name
The product name '' is invalid or does not exist.
Comment 2 Alasdair Kergon 2006-11-01 13:33:27 EST

*** This bug has been marked as a duplicate of 212266 ***

Note You need to log in before you can comment on or make changes to this bug.