Bug 21227 - no logrotate entry for ssl_request_log
Summary: no logrotate entry for ssl_request_log
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache   
(Show other bugs)
Version: 7.1
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Dale Lovelace
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-22 06:58 UTC by Arenas Belon, Carlo Marcelo
Modified: 2007-03-27 03:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-10 18:30:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arenas Belon, Carlo Marcelo 2000-11-22 06:58:06 UTC
the mod_ssl configuration keeps a log of the pages served on :

  /var/log/httpd/ssl_request_log

there is no entry on /etc/logrotate.d/apache for that file, so it could get
as big as allowed for the corresponding filesystem.

an entry should be added so it is cut and rotated as all the other apache
logs as shown :

/var/log/httpd/ssl_request_log {
 missingok
 postrotate
  /bin/kill -HUP `cat /var/run/httpd.pid 2>/dev/null` 2>/dev/null || true
 endscript
}

Comment 1 Arenas Belon, Carlo Marcelo 2000-11-24 05:44:45 UTC
dropping severity as i hope filling /var because of too much ssl hits is
something that hopefully won't happen ;)

Comment 2 Arenas Belon, Carlo Marcelo 2001-01-10 18:30:12 UTC
still not fixed for beta2

Comment 3 Nalin Dahyabhai 2001-01-12 02:30:12 UTC
This will be fixed in apache-1.3.14-7 and later.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.