Bug 212273 - FC6 does not support hyperthreading technology.
FC6 does not support hyperthreading technology.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-25 18:46 EDT by Shane Murdock
Modified: 2015-01-04 17:29 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 12:33:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shane Murdock 2006-10-25 18:46:27 EDT
Description of problem:
I have a P4 3.0 GHZ with hyperthreading technology.I have to disable
hyperthreading in bios to get the computer to boot without hanging.It always
hangs when starting sshd,or sendmail.this also occurs with FC5.

Version-Release number of selected component (if applicable):


How reproducible:This occurs 100% of the time with hyperthreading enabled.


Steps to Reproduce:
1.turn on hyperthreading in bios.
2.turn computer on.
3.
  
Actual results:It boots the kernel.When starting the services it hangs on
sshd,or sendmail.


Expected results:This computer works fine using mandriva any version.Ubuntu and
Mepis using the SMP kernel to support the 2 virtual cores of the CPU also works
fine.


Additional info:
Comment 1 Dave Jones 2006-10-28 02:27:07 EDT
any chance you could hook this up to a serial console? or netconsole?  maybe if
we get some kernel messages out of the thing just before the lockup we'll get
some clues.

does booting with acpi=off make it work again ?

something else that might be worth a try..  boot up with ht disabled, and do a
chkconfig irqbalance off, and then reboot with it enabled. See if that makes it
work again.
Comment 2 Steve Bergman 2006-11-04 15:55:37 EST
I have a similar problem on a Dell Poweredge 400sc.
There is no setting to turn hyperthreading off in the bios.

I have no problems booting up, but hyperthreading is not used.

I see in dmesg:

=============
CPU: After generic identify, caps: bfebfbff 00000000 00000000 00000000 00004400
00000000 00000000
CPU: After vendor identify, caps: bfebfbff 00000000 00000000 00000000 00004400
00000000 00000000
CPU: Trace cache: 12K uops, L1 D cache: 8K
CPU: L2 cache: 128K
CPU: Hyper-Threading is disabled
CPU: After all inits, caps: bfebf3ff 00000000 00000000 00000080 00004400
00000000 00000000
Intel machine check architecture supported.
Intel machine check reporting enabled on CPU#0.
CPU0: Intel P4/Xeon Extended MCE MSRs (12) available
CPU0: Thermal monitoring enabled
Checking 'hlt' instruction... OK.
SMP alternatives: switching to UP code
Freeing SMP alternatives: 12k freed
ACPI: Core revision 20060707
CPU0: Intel(R) Celeron(R) CPU 2.00GHz stepping 09
Total of 1 processors activated (3994.07 BogoMIPS).
ENABLING IO-APIC IRQs
..TIMER: vector=0x31 apic1=0 pin1=2 apic2=-1 pin2=-1
Brought up 1 CPUs
=================


cat /proc/cpuinfo gives me this:

=================
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Celeron(R) CPU 2.00GHz
stepping        : 9
cpu MHz         : 1995.042
cache size      : 128 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat
pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe up cid xtpr
bogomips        : 3994.07
=================
Comment 3 Steve Bergman 2006-11-04 21:32:34 EST
Oops.  Wrong bug number.  Please ignore.
Comment 4 Johan Ivarsson 2006-12-17 12:27:15 EST
I have a very similar problem with my Amilo D 1840 laptop (P4 3.0GHz)

After installing FC6, the computer was impossible to boot, it always hang
somewhere in the start-up of services. It was not until I found a hint that one
should use the kernel option nolapic that I got it to work-according to some
postings I have read this is supposed to turn off HT? (I can conclude there is
no hyperthreading going on /proc/cpuinfo shows only one proc, and in messages I
have: "SMP alternatives: switching to UP code")


I can also confirm that the smp kernel hasn't worked either for FC3, FC4 or FC5,
hang in start-up (but the non-smp has of course been fine)

If I can provide you with some information for debugging this, please let me know.
Comment 5 Peter Georgaras 2007-05-05 01:50:56 EDT
I have identical symptoms but seem to have resolved the issue with my machine
(MSI 651 M-L board with an Intel 3.06 GHz HT-capable CPU, running the standard
FC6 installed kernel).

As mentioned above, on boot up with HyperThreading (HT) enabled, my system would
stall during the starting of services.  Switching off HT in BIOS would enable a
successful boot up (using exactly the same kernel and boot-up parameters).

I tried deactivating a few non-essential (for me) services, including sendmail,
and went back into BIOS and enabled HT but on re-boot there was no change to the
situation - the stalls still persisted, always occurring during the loading of
HAL service.

Next, I tried passing "acpi=off" as boot parameter (as suggested in an earlier
post, above), I was able to successfully boot up and login - but without HT
activated, which should not be any surprise as HT needs ACPI (by using ACPI
tables for virtual processor discovery). [Reference: ACPI-HOWTO]

Using "acpi=ht" did not resolve the situation, with the system again stalled
during boot-up as before.

So I looked for something else to deactivate, whilst keeping ACPI active.

Elsewhere I read about deactivating APIC, so I  removed the "apci=off" parameter
and instead passed "noapic" and the system booted-up all OK and with HT
activated - confirmed with 2 processors in /proc/cpuinfo

Hope this provides a useful lead/solution to others.
Comment 6 Bug Zapper 2008-04-04 00:06:54 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 7 Bug Zapper 2008-05-06 12:33:02 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.