Bug 212280 - Require to add Korean keyboard option(106key)
Require to add Korean keyboard option(106key)
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
bzcl34nup
: i18n, Reopened
Depends On: 220151
Blocks: FC7Target
  Show dependency treegraph
 
Reported: 2006-10-25 21:08 EDT by Jong Bae KO
Modified: 2009-04-14 15:47 EDT (History)
4 users (show)

See Also:
Fixed In Version: F7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-14 15:47:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add Korean keys layout support (910 bytes, patch)
2007-01-09 07:59 EST, Peng Huang
no flags Details | Diff

  None (edit)
Description Jong Bae KO 2006-10-25 21:08:20 EDT
Description of problem:
Current version of system-config-keyboard doesn't have Korean keyboard option.
The latest kernel supports Korean Keyboard now.

edit in /etc/X11/Xmodmap
keycode 109 = Hangul_Hanja
keycode 113 = Hangul

#xmodmap /etc/X11/Xmodmap
or

#setxbmap kr

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2798.fc6


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 sangu 2006-10-26 01:42:23 EDT
Please See bug 204158 


Comment 2 Akira TAGOH 2006-11-09 01:36:12 EST
system-config-keyboard just uses rhpl to provide keyboard model info. reassigning
Comment 3 Jong Bae KO 2006-11-09 02:04:07 EST
other ways to set up Hangul keyboard in manually

vi /etc/X11/xorg.conf

Option "XkbLayout" "kr"

or

set up in gnome-keyboard-properties


However, anaconda and system-config-keyboard doesn't support yet.


Comment 4 Peng Huang 2006-12-18 03:08:45 EST
I checked system-config-keyboard. It will change console and Xorg keyboard's
settings. But the console setting tools loadkeys doesn't support kr layout now.
We should ask kbd to support it first.
Comment 5 Jong Bae KO 2006-12-19 01:09:21 EST
Hi phuang

Can it change only Xorg keyboard's settings by system-config-keyboard?
Because, currently SCIM is major IM on RHEL5 and FC6, and SCIM launchs on x11.
Doesn't really need to use Korean keyboard on the console.
Comment 6 Peng Huang 2006-12-19 04:27:14 EST
Hi jko,
I found some codes in rhpl listed below. Currently, s-c-k uses console layout as
diction's key, so we can not make two settings use same console layout, the
first record will be overwrite by others (with same console layout). So if we do
not make a big change (modify data structures) in s-c-k and rhpl, we can not
support kr. Or we must add a kr layout for console. :(

# NOTE: to add a keyboard model to this dict, copy the comment
# above all of them, and then the key should be the console layout
# name.  val is [N_('keyboard|Keyboard Name'), xlayout, kbmodel,
# variant, options]
self._modelDict = {
    ...    
    'us'               : [N_('keyboard|Korean'), 'us', 'pc105', '', ''],
    ...
    ...
    'us'                      : [N_('keyboard|U.S. English'), 'us', 'pc105', '',
''],
}   
Comment 7 Peng Huang 2007-01-09 07:59:24 EST
Created attachment 145155 [details]
Add Korean keys layout support

Add Korean keys layout support. And it need kbd >= 1.12-21 (it added Korean
support too).
Comment 8 Peng Huang 2007-01-09 21:15:25 EST
I checked the new source code. The name of Korean X key layout should be 'kr'.

+            'ko'               : [N_('keyboard|Korean'), 'kr', 'pc105', '', ''],
                                                           ~~~
Comment 9 Peng Huang 2007-01-11 00:49:50 EST
Fixed in 0.199-1.
Comment 10 Jong Bae KO 2007-01-11 02:08:29 EST
Hi phuang,

Will Hangul Keyboard option be included in anaconda? 
Comment 11 Peng Huang 2007-01-11 03:00:56 EST
Hi jko,
I checked the code. Anaconda invokes rhpl. So it should support Korean keyboard
too. We could test it in a future beta release.
Comment 12 Jong Bae KO 2007-01-11 19:59:23 EST
Thanks Phuang,

Yes, It is.
I will test it in the future best release.
Comment 13 A S Alam 2007-05-19 05:32:01 EDT
 system-config-keyboard has 'kr' included, but not option found in
system config as mention in bug
--
keycode 109 = Hangul_Hanja
keycode 113 = Hangul
--
anybody please update what need to check
Comment 14 Red Hat Bugzilla 2007-08-21 01:27:46 EDT
User pnasrat@redhat.com's account has been closed
Comment 15 Jens Petersen 2007-09-19 01:56:09 EDT
I believe this is fixed in F7 already.
Comment 16 Jens Petersen 2007-09-19 01:58:34 EDT
Sorry may still need to address comment 13.
Comment 17 Bug Zapper 2008-04-03 14:32:45 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 18 Bug Zapper 2008-05-13 22:26:01 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 19 Tony Fu 2008-09-09 23:13:35 EDT
requested by Jens Petersen (#27995)
Comment 20 Fedora Admin XMLRPC Client 2009-04-14 15:22:02 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 21 Chris Lumens 2009-04-14 15:47:41 EDT
I see this bug was reopened, but I see no additional comments indicating why.  Closing out again for now.  If it's not actually fixed, please say that instead of just reopening it.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.