Bug 212283 - alot of 4gb fixup messages on console.
alot of 4gb fixup messages on console.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-25 21:32 EDT by Itamar Reis Peixoto
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-26 13:02:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Itamar Reis Peixoto 2006-10-25 21:32:43 EDT
Description of problem:
I have alot of 4gb fixup messages on console. (xm console)

4gb seg fixup, process updateuserdomai (pid 9490), cs:ip 73:001977c2
printk: 274779 messages suppressed.
4gb seg fixup, process httpd (pid 9479), cs:ip 73:001fb48e
printk: 227828 messages suppressed.
4gb seg fixup, process pop3login (pid 9502), cs:ip 73:0027700f
printk: 35278 messages suppressed.
4gb seg fixup, process check_perms (pid 9499), cs:ip 73:00da5ee4
printk: 28900 messages suppressed.
4gb seg fixup, process check_perms (pid 9499), cs:ip 73:00df312d
printk: 7521 messages suppressed.
4gb seg fixup, process python2.4 (pid 8648), cs:ip 73:00d9c116
printk: 211596 messages suppressed.
4gb seg fixup, process syslogd (pid 26280), cs:ip 73:00b05116
printk: 473071 messages suppressed.
4gb seg fixup, process hackcheck (pid 9514), cs:ip 73:002037c2
printk: 520920 messages suppressed.
4gb seg fixup, process python2.4 (pid 8648), cs:ip 73:00d9c116


Version-Release number of selected component (if applicable):

Linux vps.ispbrasil.com.br 2.6.18-1.2798.fc6xen #1 SMP Mon Oct 16 15:11:19 EDT
2006 i686 i686 i386 GNU/Linux


How reproducible:
xm console domU


Expected results:

Can you check for me if this patche disable this message and inclue it on next
xen-kernel release ?

http://xenbits.xensource.com/xen-unstable.hg?fd=1633f9a3a120;file=linux-2.6-xen-sparse/arch/i386/kernel/fixup.c


another question:

This messages can cause slow down on domU, if disable this messages my domU's
will run more fast ?


thanks for your help.
Comment 1 Stephen Tweedie 2006-10-26 05:33:26 EDT
That patch will not help.

The trouble is, mixing positive and negative segment offsets is slow under Xen.
 In practical terms, that means that applications linked statically against some
older, pre-FC6 libraries are going to be slow.  

FC-6 uses a "nosegneg" library variant, autodetected at run time, to avoid this
on Xen.  But applications linked statically against an older libc will still use
negative segment offsets, and will still take a kernel fault each time they try
to do so.

The log messages are simply telling you that these faults are occurring.  The
log is rate-limited to at most one per second, so its overhead should be
minimal; but the segment fixups that it is reporting indicate a genuine slowdown
that the user needs to be aware of.

In your case, all these fixup messages are unexpected --- httpd, python, syslogd
etc. should all be using nosegneg with FC-6.  Are you perhaps using an FC-6
kernel on an older rawhide or Fedora?
Comment 2 Itamar Reis Peixoto 2006-10-26 12:53:48 EDT
yes,

I am using a fc6 kernel to run fedora 4, 5, 6 and debian and other's  domU's

Comment 3 Itamar Reis Peixoto 2006-10-26 12:57:12 EDT
the fc6 kernel seems to be running more slow than old version provided by 
xensource.

xen-3.0.1-12.1_fc4.i386.rpm
xen-kernel-2.6.12-xen3_12.1_fc4.i686.rpm

and I have changed from "file://" to "tap:aio" in domU config files.

any help to incresy performance of my domU's ?
Comment 4 Rik van Riel 2006-10-26 13:02:51 EDT
The 4GB segmentation fixup message does not cause things to run slower.

Instead, it signals when things are running slow, because userspace is using
negative segment offsets.

You will want to run with a nosegneg glibc variant to speed things up.  

Changing the kernel is not going to help at all.
Comment 5 Itamar Reis Peixoto 2006-10-28 01:34:14 EDT
Hi.

I am using fc6-dom0 and fc6-domU and I am still receiving this message.

this is normal ?
Comment 6 Daniel Berrange 2006-10-28 10:33:27 EDT
As Rik says in comment #4, it is not the kernel which matters here. You need to
use a newer glibc which comes with a 'nosegneg' variant to fix the problem.

# rpm -q glibc
glibc-2.5-3
# rpm -ql glibc | grep nosegneg
/lib/i686/nosegneg
/lib/i686/nosegneg/libc-2.5.so
/lib/i686/nosegneg/libc.so.6
....
Comment 7 Itamar Reis Peixoto 2006-10-28 11:57:38 EDT
to use nosegneg glibc

echo "hwcap 0 nosegneg" > /etc/ld.so.conf.d/nosegneg.conf

this will stop messages on console 

Comment 8 Stephen Tweedie 2006-10-28 18:03:56 EDT
The hwcap should not be necessary: the kernel-xen package already includes an
appropriate ld.so.conf file:

   # cat /etc/ld.so.conf.d/kernelcap-2.6.18-1.2798.fc6.conf
   ...
   hwcap 0 nosegneg

If there are specific binaries still inducing this error, then please do report
those.  

Note You need to log in before you can comment on or make changes to this bug.