Bug 21231 - "found a bug" message during RH7 installation
"found a bug" message during RH7 installation
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-22 04:23 EST by Paul Hamer
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-22 11:58:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Hamer 2000-11-22 04:23:36 EST
Yesterday I installed RH7 on my PII-300 system with IDE Harddisk and a 2940SCSI with CDD2600 + Iomega ZIP. In the disk partition tool (not 
fdisk, the other one) my CDD2600 (no media inserted) showed up as a device with a large negative number as free space and size. The ZIP 
showed up correctly (media inserted). Then I assigned a mount point to the ZIP ( /mnt/zip ).... Then continued the installation with formatting 
my 
harddrive (with checking for bad blocks). This took quite a while so I went away. When I returned, there was an error message on my screen, 
saying "this is probably a bug, please report it", so here I am. Below is the text that was saved to disk by the "bug reporter". After this my PC 
rebooted, so I simply retried (what else), but this time I did not specify a mount point for my Zip... no problems this time.

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in doInstall
    if self.method.systemMounted (self.fstab, self.instPath, self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//mnt/zip

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Daniel Roesen 2000-11-22 11:58:47 EST
Errata update available.
Comment 2 Daniel Roesen 2000-11-22 12:00:38 EST

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.