Bug 212317 - Edit LVM partition crash on install
Edit LVM partition crash on install
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Depends On:
  Show dependency treegraph
Reported: 2006-10-26 04:23 EDT by Frederic Ruaudel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-01 15:00:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
anaconda dump file (66.04 KB, text/plain)
2006-10-26 04:23 EDT, Frederic Ruaudel
no flags Details
My LVM config (pvdisplay, vgdisplay and lvdisplay) (3.04 KB, text/plain)
2006-10-26 13:26 EDT, Frederic Ruaudel
no flags Details
My home LVM config (pvdisplay, vgdisplay and lvdisplay) (3.29 KB, text/plain)
2006-10-26 15:36 EDT, Frederic Ruaudel
no flags Details

  None (edit)
Description Frederic Ruaudel 2006-10-26 04:23:20 EDT
Description of problem:

I tried to install FC6 Zod on an already existing LVM partition and when I
select a LVM partition and click edit, the installation crashes.

Version-Release number of selected component (if applicable):

FC6 Zod final

How reproducible:


Steps to Reproduce:
1.Create some LVM partition on a SATA disk (I have an LVM on 2 disk : one 80GB
and one 120GB)
2.Boot with the FC6 install DVD
3.Select English language and French keyboard
4.Select create custom layout
5.Select an LVM partition and click edit
Actual results:

It crashes

Expected results:

A dialog to edit my partition

Additional info:

See attached bug report saved from the "Exception Occured" dialog
Comment 1 Frederic Ruaudel 2006-10-26 04:23:20 EDT
Created attachment 139445 [details]
anaconda dump file
Comment 2 Chris Lumens 2006-10-26 10:50:06 EDT
What physical extent size did you use for the volume you created?
Comment 3 Frederic Ruaudel 2006-10-26 13:26:17 EDT
Created attachment 139491 [details]
My LVM config (pvdisplay, vgdisplay and lvdisplay)
Comment 4 Frederic Ruaudel 2006-10-26 13:27:47 EDT
Here is my full LVM config info attached (PE=1M). 

So, for the record, I resize my old root partition LogVolRoot by hand (resize2fs
and lvreduce) and create the second root partition LogVolRoot2 (lvcreate and
mkfs.ext3). Then during the installation I select the LogVolRoot2 partition and
click "Edit", then crash. It was the same when I tried to edit one of the others.

It also crashes when I create a fresh new layout on another disk but keep the
two lvm disks active. But in this configuration it crashes when I clicked 'Next'
(Not sure if it is the same bug).

I finally manage to install FC6 after disabling the two disks and only keep the
one with the fresh new layout.

I will try to install FC6 on my home machine with the same config but the LVM is
on one disk only and PE=4M. I will come back and tell you if the problem occurs

Comment 5 Frederic Ruaudel 2006-10-26 15:36:30 EDT
Created attachment 139520 [details]
My home LVM config (pvdisplay, vgdisplay and lvdisplay)

Come back from my second test, it works fine with 1 disk and PE=4M. 

Maybe an important note to add, this time it was done in text mode since my
#!ยง%@# ATI card has been detected as a Matrox Millenium by anaconda and thus
the install fall back in text mode.
Comment 6 Chris Lumens 2006-11-01 15:00:23 EST
Yeah, this only fails if your PE size is 1 MB due to some sloppy python code. 
I've committed a fix to Rawhide.  A workaround for you is to simply use any
other PE size.  Thanks for your help in debugging this.

Note You need to log in before you can comment on or make changes to this bug.