Bug 212320 - sata_promise fails at boot
sata_promise fails at boot
Status: CLOSED DUPLICATE of bug 199142
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 05:43 EDT by Markus Hakansson
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 15:38:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dmesg that shows the error that occured (16.00 KB, text/plain)
2006-10-26 05:43 EDT, Markus Hakansson
no flags Details

  None (edit)
Description Markus Hakansson 2006-10-26 05:43:07 EDT
Description of problem:
During kernel initialisation sata_promise gives the error
 Unable to handle kernel NULL pointer dereference at 0000000000000008 RIP:
[<ffffffff883285cd>] :sata_promise:pdc_sata_scr_read+0x18/0x1b

The machine tries to continue. With FC5 it stopped at udev trying to initialise
devices and did not continue.

Version-Release number of selected component (if applicable):
All kernels from 2.6.17, tested with FC5, have this problem but I have been
unable to catch the problem since it has scrolled past my screen.
I have a promise SATA controller but no SATA-devices, only two IDE hd's and one
IDE DVD-burner.

When starting the installer for FC6 I get the same message but this time I was
able to get the dmesg into a file that I now included. So the included file is
the error with FC6 installation kernel, but I get this same problem with
FC5-kernels 2.6.17 and 2.6.18.
Kernel up to (and including) 2.6.16 works perfectly.
Comment 1 Markus Hakansson 2006-10-26 05:43:07 EDT
Created attachment 139447 [details]
Dmesg that shows the error that occured
Comment 2 White FrosT 2006-10-28 10:21:38 EDT
I have what looks like the same problem while trying to install FC6 release on 
a virgin X86 machine (So the 32 bit version, not the 64 like Markus).

Discussion of my problem can be found at the found at the forum;
http://forums.fedoraforum.org/showthread.php?p=659942
Comment 3 Phil Schaffner 2006-11-09 06:52:02 EST
Similar problems here with SATAII150 TX2plus controller.  Was able to install in
text mode on a PATA drive on a different controller with the "noprobe" option,
but no SATA drives are seen either at install time or on subsequent boot.  The
re-boot hung for a long time after the sata_promise errors but finally
completed.  Ran updates and rebooted with similar delay after modprobe, but
seens to be permanently hung at "Bringing up interface eth0:".
Comment 4 Phil Schaffner 2006-11-10 08:52:37 EST
Work-around was to boot CentOS4 from another disk (could have used rescue disk)
and edit /etc/modprobe.conf adding a line

  install sata_promise /bin/true

to disable the module.  This does not help those who need to use the controller,
nor get me access to the 250G SATA disk on the TX2plus, but does get FC6 to boot.

BTW - this is a 32-bit install on an Athlon processor.  Also, during install the
text screen fonts changed to something that looked like Cyrillic around the time
the problem was encountered.  Have seen references to such font problems in
other references to similar sata_promise driver issues.

Comment 5 White FrosT 2006-11-13 07:41:15 EST
Bug is still present in kernel release 2.6.18-1.2849.fc6.
Comment 6 Dan Carpenter 2006-11-13 12:38:09 EST
this is the same as bug 199142
Comment 7 Markus Hakansson 2006-11-13 15:38:27 EST

*** This bug has been marked as a duplicate of 199142 ***

Note You need to log in before you can comment on or make changes to this bug.