Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 212328 - [RHEL5] Evolution doesn't apply changed 'hide completed tasks' setting immediately.
[RHEL5] Evolution doesn't apply changed 'hide completed tasks' setting immedi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: evolution (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 06:44 EDT by Petr Muller
Modified: 2016-09-19 22:04 EDT (History)
1 user (show)

See Also:
Fixed In Version: evolution-2.12.3-8.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-20 10:09:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Muller 2006-10-26 06:44:55 EDT
Description of problem:
Evolution doesn't apply changed time in 'hide completed tasks' setting 
immediately.  If you change the time after task should be hidden, and complete 
some task, it is hidden after old value of time, not the new.
If you reload the task list somehow (e.g. restart Evolution, switch to mail and 
back to tasks, etc), the new settings applies.

Version-Release number of selected component (if applicable):
Evolution 2.8.0

How reproducible:
always

Steps to Reproduce:
1. Create a few tasks and make sure 'Hide completed tasks' is disabled in 
preferences
2. Change settings to be 'Hide completed tasks after 1 minute'
3. Make one task completed
4. Wait one minute. Completed task hides.
5. Change settings to be 'Hide completed tasks after 0 minute'
6. Make other task completed. It hides after 1 minute, but it should hide 
immediately.
  
Actual results:
Changed settings are applied after reloading the task list somehow.

Expected results:
Changed settings are applied by closing settings dialog.

Additional info:
Comment 1 Matthew Barnes 2008-03-16 18:39:07 EDT
RHEL 5.2 will re-base Evolution from version 2.8.0 to version 2.12.3.
Can you please test whether this bug is still present in RHEL 5.2?
Comment 2 Petr Muller 2008-03-20 08:27:32 EDT
This bug seems to be fixed in RHEL5.2 evo
Comment 3 Matthew Barnes 2008-03-20 10:09:05 EDT
Thanks for responding.  I'll close this as CURRENTRELEASE then.

Note You need to log in before you can comment on or make changes to this bug.