Bug 212332 - New(added) people to a bug do not get a parent E-mail for proper message threading
New(added) people to a bug do not get a parent E-mail for proper message thre...
Status: CLOSED UPSTREAM
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 07:57 EDT by Paul Dickson
Modified: 2013-06-23 22:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-11 10:26:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Dickson 2006-10-26 07:57:06 EDT
Description of problem:
Currently, only the original participants of a bug receive the first message
which is the parent of all additional comments E-mailed.

Please enhance bugzilla to send the first, parent message (or a place holder) to
each new particpant so further messages have something to be threaded against.

I'd even put up with multiple such messages if I removed myself and later
re-added myself again.

Version-Release number of selected component (if applicable):
2.18

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Adding myself to a bug report results in all E-mail linked as replies to the
Message-ID of the initial report.  But I did not receive this message (not being
a participant).  My MUA does not, therefore, thread the messages.

Expected results:
When I add myself to a bug report, I would like either the first message or a
short place holder sent to me, both having the Message-ID of the original first
E-mail.

Additional info:
MUA's are fairly dumb, so the parent of the bug thread doesn't have to be sent
first.  I could be sent after the message adding an individual it sent, but the
parent threaded message should only added to those individuals being added.
Comment 1 Mark McLoughlin 2008-08-06 03:10:39 EDT
The In-Reply-To header makes threading work fine for most people e.g.

  In-Reply-To: <bug-446214-196610@bugzilla.redhat.com>

Which MUA is this?
Comment 2 Paul Dickson 2008-08-10 05:16:34 EDT
The In-Reply-To header can only work if the first bugzilla message is available to the MUA.  This is not the case for people who add themselves to a bug after the first bug notification has been added.

The In-Reply-To header is set by Bugzilla since E-mail replies are not allowed.

MUA like Sylpheed do not sort messages by threads if the In-Reply-To header (the parent message) does not exist.

Perhaps Bugzilla should use the References to list the message IDs of messages of a bug.
Comment 3 Mark McLoughlin 2008-08-11 04:42:22 EDT
(In reply to comment #2)
> The In-Reply-To header can only work if the first bugzilla message is available
> to the MUA.

Evolution handles this fine - perhaps your suggestion could be implemented in bugzilla but, given the bug is nearly two years old :-), it might be more worthwhile to get Sylpheed to thread purely based on In-Reply-To if it can't find the original Message-Id referred to.
Comment 4 David Lawrence 2008-08-11 10:26:51 EDT
We are using the stock Bugzilla code now available upstream (3.2rc1) so this will probably be best addressed in the upstream and then Red Hat will apply the needed fixes later.

Please file at:

https://bugzilla.mozilla.org/enter_bug.cgi?product=Bugzilla&component=Email+Notifications

Thanks
Dave

Note You need to log in before you can comment on or make changes to this bug.