Bug 212344 - Many unneeded kernel modules are loaded
Summary: Many unneeded kernel modules are loaded
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Jon Masters
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On: 211780
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-26 13:49 UTC by Linda Wang
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-10 11:16:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Linda Wang 2006-10-26 13:49:37 UTC
+++ This bug was initially created as a clone of Bug #211780 +++

Description of problem:
Using kernel-2.6.17-1.2293_FC6, not much overhead was loaded: video button 
battery ac lp parport_pc parport.

But things changed using kernel-2.6.18-1.2798.fc6: button battery asus_acpi ac 
scb2_flash mtdcore cfi_probe chipreg map_funcs pcspkr sbs i2c_ec parport_pc lp 
parport i2c_piix4 i2c_core gen_probe serio_raw video

Why do you believe I need this whole mess automatically loaded? I'm accepting 
video as there is a graphics controller and maybe the ACPI stuff even it doesn't 
make sense at a server, but the rest seems more than nonsens to me. And the box 
has neither parport nor for Linux usable i2c/SMBus or any Asus components. There 
even isn't a sound card or a beeper which could be used for pcspkr. Ha and ever 
seen a 1U rack server supporting any type of CFI-compliant flash chips?

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2798.fc6

How reproducible:
Buy a HP ProLiant DL360 G3, G4, G4p or G5 and install Fedora Core 6. You'll get 
the same mess installing Red Hat Enterprise Linux 5 when ready and not fixed...

Actual results:
Many unneeded kernel modules are loaded.

Expected results:
Only kernel modules loaded which are really needed and not just every module 
standing or lying around and looking a bit pretty... ;-)

Additional info:
The following also looks strange to me (ehci, ohci and uhci at the same time?):

ehci_hcd               35533  0
ohci_hcd               25181  0
uhci_hcd               27725  0

Comment 2 Jon Masters 2006-11-10 11:16:32 UTC
It looks like this is a case of a newer kernel providing updated drivers
(modalias, new hardware support) that udev then loads automatically on boot. I
don't really see what the bug is here - it's possible to tell the tools not to
load these drivers, if you really want. Unless I'm missing something, this is
not actually a "bug", more a feature that's resulting in some extra modules loaded.


Note You need to log in before you can comment on or make changes to this bug.