Bug 212350 - desktop-file-{install,validate} do not accept X-* categories
desktop-file-{install,validate} do not accept X-* categories
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: desktop-file-utils (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 10:19 EDT by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-28 11:17:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Accept categories starting with "X-" (293 bytes, patch)
2006-10-26 10:19 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2006-10-26 10:19:23 EDT
desktop-file-{install,validate} from desktop-file-utils 0.11 do not accept 
extension categories starting with "X-", but the desktop menu spec says that's 
what one should use for nonstandard extensions:

http://standards.freedesktop.org/menu-spec/latest/ar01s03.html
"Categories not in this document must be prefixed by the string "X-" 
indicating that they are extensions."

For example:

$ desktop-file-validate /usr/share/applications/gaim.desktop
[...]
/usr/share/applications/gaim.desktop: error: Categories values must be one of 
[...] (found "X-Red-Hat-Base")

Reported here because of no desktop-file-utils component in upstream Bugzilla 
(https://bugs.freedesktop.org/show_bug.cgi?id=4959)

It also rejects the "Application" category, but that's ok, as it's not a 
standard one.  Patch attached.
Comment 1 Ville Skyttä 2006-10-26 10:19:23 EDT
Created attachment 139463 [details]
Accept categories starting with "X-"
Comment 2 Ray Strode [halfline] 2006-10-26 13:44:32 EDT
Hey thanks for the patch.  I'm going to be doing an upstream desktop-file-utils
release soon, i'll fold this in.
Comment 3 Matthias Clasen 2006-10-28 11:17:35 EDT
Should be fixed in desktop-file-utils-0.11-4

Note You need to log in before you can comment on or make changes to this bug.