Bug 21239 - xterm does not send escape sequences for numeric keypad
xterm does not send escape sequences for numeric keypad
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-22 08:34 EST by nvwarr
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-04 05:57:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nvwarr 2000-11-22 08:34:38 EST
Even when "Enable Application Keypad" is selected, xterm is sending normal
numbers rather than escape sequences for the numeric keypad. This breaks
the edt emulation in jed, among other things.

The version of xterm shipped with RH6.2 does not have this problem (even if
used with XFree86 4.0.1)
Comment 1 nvwarr 2000-11-26 04:52:59 EST
Workaround: add a modifier Num_Lock with xmodmap. It doesn't matter which
modifier it is, nor if it is bound to a key which actually exists. The function
VTInitModifiers in input.c detects the existence of the modifier and then xterm
sends the correct escape sequences, making it possible for jed to work.

It would appear from line 443 of input.c that this behaviour is deliberate. i.e.
if there is no Num_Lock key, never give escape sequences for the numeric keypad,
just the normal numbers. In this case, there is no way for the application to
distinguish between a number key on the main keyboard and one on the numeric
keypad. This behaviour is different from previous versions of xterm. Is there a
good reason for the new behaviour?
Comment 2 Mike A. Harris 2001-03-31 10:16:08 EST
Not a bug.  This is a configuration issue as you've noted.  xmodmap
is the way to go.

Note You need to log in before you can comment on or make changes to this bug.