Bug 212399 - Marvell ethernet lost promisc state
Marvell ethernet lost promisc state
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Andy Gospodarek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-26 13:46 EDT by Bruno A. Crespo
Modified: 2014-06-29 18:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-08 18:15:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (401 bytes, patch)
2006-11-28 12:30 EST, Andy Gospodarek
no flags Details | Diff
netdev patch (1.25 KB, patch)
2006-12-20 16:21 EST, Andy Gospodarek
no flags Details | Diff

  None (edit)
Description Bruno A. Crespo 2006-10-26 13:46:18 EDT
Description of problem:

After a link down / link up cicle the ethernet card loses the promisc state, 
ifconfig shows PROMISC, but the programs doesn't receive packets.  Unset and 
reset the promisc state solves the problem.

Version-Release number of selected component (if applicable):

uname -a:
Linux servidor.fuenlabrada.calvoymunar.com 2.6.17-1.2187_FC5 #1 Mon Sep 11 
01:17:06 EDT 2006 i686 athlon i386 GNU/Linux

Ethernet card:
Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
How reproducible:


Steps to Reproduce:
1. start tcpdump
2. disconnect and connect the ethernet cable
3. start a rpl client in the network
4. tcpdump doesn't show the packets
5. restart tcpdump and it sees the packets
  
Actual results:

Loses promisc status.

Expected results:

Maintains promisc status
Additional info:
Comment 1 Andy Gospodarek 2006-11-28 12:30:27 EST
Created attachment 142309 [details]
proposed patch

I will probably push this patch upstream since it should resolve your issue.  

I would like to test it out first, but don't have access to any hardware today.
 Would a test-build be helpful or would you like to try this patch yourself? 
If you would like a test-build let me know what ARCH you would like and I can
put one together.
Comment 2 Bruno A. Crespo 2006-11-28 14:16:32 EST
The machine that has the problem is a production server, please, give me two 
or three days to schedule a reboot.  Thanks.
Comment 3 Andy Gospodarek 2006-11-30 12:07:41 EST
I posted the patch from Comment #1 to netdev since it seemed fine to me.
Comment 4 Andy Gospodarek 2006-12-20 16:21:54 EST
Created attachment 144141 [details]
netdev patch

This patch was proposed and accepted upstream as a result of the patch I
posted.
Comment 5 Andy Gospodarek 2007-02-01 14:43:24 EST
Were you able to build a test kernel with the patch from Comment #4 and verify
that it resolved your issue?
Comment 6 Andy Gospodarek 2007-03-08 18:15:01 EST
This fix should be in 2.6.20.

Note You need to log in before you can comment on or make changes to this bug.