Bug 2124145 - show-upgrade-prerelease does not prompt GNOME Software for a system upgrade
Summary: show-upgrade-prerelease does not prompt GNOME Software for a system upgrade
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: distribution
Version: 37
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Cotton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F37BetaBlocker
TreeView+ depends on / blocked
 
Reported: 2022-09-05 03:00 UTC by remyabel
Modified: 2022-09-08 13:49 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-08 13:49:28 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Fedora Pagure fedora-infrastructure issue 10880 0 None None None 2022-09-05 08:48:02 UTC

Description remyabel 2022-09-05 03:00:39 UTC
Description of problem:

When testing if Fedora 36 can upgrade to the Fedora 37 pre-release, following the test case instructions (https://fedoraproject.org/wiki/QA:Testcase_upgrade_gnome-software_current_workstation) should result in GNOME Software showing a notification to upgrade.

Version-Release number of selected component (if applicable):

gnome-software-42.4-1.fc36.src.rpm

How reproducible:

Always.

Steps to Reproduce:
1. Boot a Fedora 36 VM
2. Do a system update via GNOME Software and reboot
3. Log in/out or reboot
4. Run gsettings set org.gnome.software show-upgrade-prerelease true and optionally set upgrade-notification-timestamp
5. Wait for notification. If no notification appears, open GNOME Software and click the refresh button manually

Actual results:

No notification appears. No prompt to upgrade appears when refreshing the updates tab.

Expected results:

Prompt or notification to upgrade appears.

Additional info:

Comment 1 Milan Crha 2022-09-05 08:48:03 UTC
Thanks for a bug report. The problem is that the

   https://admin.fedoraproject.org/pkgdb/api/collections/

returns version `devel`, instead of `37`, for the pre-release.

I opened this there:
https://pagure.io/fedora-infrastructure/issue/10880

Please see it for any further updates.

Comment 2 Kamil Páral 2022-09-07 15:00:48 UTC
This is a Beta blocker:
https://fedoraproject.org/wiki/Fedora_37_Beta_Release_Criteria#Upgrade_requirements

Reopening for blocker-tracking purposes.

Comment 3 Ben Cotton 2022-09-07 19:34:38 UTC
https://pagure.io/fedora-infra/ansible/pull-request/1180 is merged and https://admin.fedoraproject.org/pkgdb/api/collections/ looks correct to me. @kparal can you verify?

Comment 4 Milan Crha 2022-09-08 06:07:16 UTC
Works fine for me now, but I'll keep the final word to Kamil.

One note, the gnome-software does not refresh the info every time it's asked for, there is set some delay between downloads of the data from the server. If it won't offer you the pre-release, close the gnome-software (`gnome-software --quit`) and then move away ~/.cache/gnome-software/fedora-pkgdb-collections/fedora.json , the file will be re-downloaded the next start. The file had been updated automatically for me, no file playing needed, because I had gnome-software off for a day or more.

Comment 5 Kamil Páral 2022-09-08 13:49:28 UTC
I can confirm that on both F35 and F36, gnome-software now detects F37 Beta (after following the testcase instructions), packages can be downloaded and the upgrade process started.


Note You need to log in before you can comment on or make changes to this bug.